[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [vfio-users] can't get my video card to connect to my vm



On Tue, Mar 8, 2016 at 3:20 PM, Stein van Broekhoven <stein aapjeisbaas nl> wrote:
I tried 2 things to avoid: "fglrx driver claiming the interrupt"
Start vm before fglrx gets to claiming it. (bad idea!)

Edit xorg related config to see what is connecting the driver to the card. (better idea)
All i found was PCI:1:0:0 (first GPU) in the config
Also tried "# aticonfig --adapter=0 --initial" and got the same config as my system created for me.

Any ideas on how i can keep the following process from claiming it?
dmesg:
[   12.361476] <6>[fglrx] Firegl kernel thread PID: 659
[   12.361547] <6>[fglrx] Firegl kernel thread PID: 660
[   12.361616] <6>[fglrx] Firegl kernel thread PID: 661
[   12.361730] <6>[fglrx] IRQ 55 Enabled
[   12.439300] <6>[fglrx] Reserved FB block: Shared offset:0, size:1000000
[   12.439302] <6>[fglrx] Reserved FB block: Unshared offset:fab4000, size:4000
[   12.439303] <6>[fglrx] Reserved FB block: Unshared offset:fab8000, size:548000

ps faux:
root         2  0.0  0.0      0     0 ?        S    22:53   0:00 [kthreadd]
...
root       659  0.0  0.0      0     0 ?        S    22:53   0:00  \_ [firegl]
...

As I said before, you need to use pci-stub or vfio-pci to prevent fglrx from claiming the device, follow something like this guide -  http://vfio.blogspot.com/2015/05/vfio-gpu-how-to-series-part-3-host.html

I can't guess why trying to start the vm before fglrx was a "bad idea" in your first case, getting pci-stub or vfio-pci bound to the device before fglrx can break it is usually the recommended practice.  In the simplest case, just add pci-stub.ids=1002:6758 to your kernel commandline.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]