[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[vfio-users] Fwd: Passing through an intregrated Nvidia mobile GPU (NVIDIA Quadro M1000M)




---------- Forwarded message ----------
From: Thomas Arouge <agentlecomputer gmail com>
Date: Thu, Mar 31, 2016 at 10:53 AM
Subject: Re: [vfio-users] Passing through an intregrated Nvidia mobile GPU (NVIDIA Quadro M1000M)
To: Mail admin <bulk frags us>


That was one suggestion that someone told me in another forums, but when I tried to do that, it displayed the Linux desktop and also showed from the xrandr command. So it seems to be hooked up to the Intel GPU, although I have not tried from the USB Type-C connector (although I do not have an adaptor for it).

On Thu, Mar 31, 2016 at 10:16 AM, Mail admin <bulk frags us> wrote:
I have a Precision M4800 that I'd been working with before, I'll pick it up again and see if I can help out.

One answer I do have for you, at least if the 5510 is wired the same way as the M4800: The HDMI output is wired to the Nvidia GPU directly. Displayport and VGA are connected to the Intel GPU. Internal panel is connected to the Intel GPU (obviously).

On Thu, Mar 31, 2016 at 1:10 PM, Thomas Arouge <agentlecomputer gmail com> wrote:
So I got my new laptop (Dell Percision 5510) and found out that this machine is able to do PCI passthrough when I took a look at the bios.

First off, here are the specs of my Laptop:
CPU: Intel(R) Core(TM) i7-6820HQ CPU @ 2.70Ghz
Integrated GPU: Intel® HD Graphics 530 (This is used on the Linux Desktop)
Discrete GPU: NVIDIA Quadro M1000M (This is what I want to use on the VM)
Motherboard: Dell 0N8J4R (I do know that this motherboard support I/O passthrough since it shows the option on the bios).
Ram: 8gb (I plan to upgrade to 32gb)
OS: Arch Linux/Stock Kernel


Here is the config on the Virtual Machine:
Inline image 1
Inline image 2
Inline image 3
(Also I actally use the spice server and virtual gpu to access the Windows Virtual Machine since I have no idea as to how I can directly connect the display to the GPU. I just happened to remove those two since I was try something)

Hypervisor Details:
Hyervisor: KVM
Architecture: x86_64
Emulator: /usr/sbin/qemu-system-x86_64
Chipset: i440FX

For frimware, I downloaded the OVMF from http://www.tianocore.org/ovmf/
 
I tried using the Git version from kraxel's website, https://www.kraxel.org/repos/jenkins/edk2/
 
, but it would be stuck in the boot screen.

I didn't really follow one guide, I looked at multiple guides online and I was able to do most of the requirements. So now I am up to the point where I am able to load the GPU and already have Windows installed. But when I try to install the Nvidia drivers, it could not detect the GPU driver. The weird thing is that the Offical Driver Finder Tool on Nvidia's website was able to detect the GPU that I was passing through.


I hope you can help me!
Tom A.

P.S. I never really used a mailing list before so I apologize if I mess something up! Also if I am missing anything, please tell me!

_______________________________________________
vfio-users mailing list
vfio-users redhat com
https://www.redhat.com/mailman/listinfo/vfio-users
 






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]