[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [vfio-users] AMD Ryzen Nested Page Table Performance Oddities



On Thu, Apr 20, 2017 at 12:57 PM, Graham Neville
<grahamneville gmail com> wrote:
> So turns out a Linux guest with Q35 and OVMF can work with npt on or off.
> However a Linux guest with i440fx only works with npt disabled.
>
> I'll follow the iommu mailing list for updates with regards to NPT affecting
> GPU FPS performance.
>
>
> On 18 Apr 2017 16:14, "Nick Sarnie" <commendsarnex gmail com> wrote:
>>
>> On Tue, Apr 18, 2017 at 10:09 AM, Graham Neville
>> <grahamneville gmail com> wrote:
>> > Has there been any feedback on this at all?
>> >
>> > I'm still struggling to get a Windows and Linux VM working at the same
>> > time
>> > with npt=1. Annoying as I'm having to reboot in to a different kernel if
>> > I
>> > want to use one or the other.
>> >
>> > Are you able to share your Kernel command line and XML for the Linux
>> > host
>> > please?
>> >
>> >
>> > On 7 Apr 2017 22:54, "Nick Sarnie" <commendsarnex gmail com> wrote:
>> >
>> > I can't reproduce that issue, I tested a Fedora VM with both npt 0 and
>> > 1, of course with the same GPU performance results as windows. I've
>> > mailed some AMD guys and KVM guys, and hopefully someone can at least
>> > figure out what is going on. Also, Alex has reproduced this himself on
>> > both Nvidia and AMD GPUs.
>> >
>> > On Fri, Apr 7, 2017 at 5:49 PM, Graham Neville <grahamneville gmail com>
>> > wrote:
>> >> Sarnex,
>> >>
>> >> I have similar oddities with npt with Ryzen. As you say with
>> >> kvm-amd.npt=0
>> >> the GPU performance is so much better (In my Witcher3 tests I'm going
>> >> from
>> >> 40fps to 75fps!). However with npt disabled the Windows10 VM slows down
>> >> an
>> >> awful lot in general tasks.
>> >>
>> >> I've also noticed that I can only run a Linux guest with kvm-amd.npt=0,
>> >> if
>> >> I
>> >> have it set to enabled then the Linux guest fails to start. I have the
>> >> same
>> >> issue even just trying to install Linux from an ISO, it will crash at
>> >> the
>> >> GRUB install menu.
>> >>
>> >> Hopefully someone knows a fix for this.
>> >>
>> >> _______________________________________________
>> >> vfio-users mailing list
>> >> vfio-users redhat com
>> >> https://www.redhat.com/mailman/listinfo/vfio-users
>> >>
>> >
>> >
>>
>> Alex emailed Paolo, the KVM maintainer, some traces but he couldn't
>> find anything in them. Please follow the thread on the iommu mailing
>> list for more details. For now, I think we have to disable NPT.

What do you mean "work"? Do you not see the GPU performance
degradation with NPT enabled on Q35 and OVMF? All settings work for
me, it's just that enabling NPT nukes FPS.

Sarnex


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]