[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [virt-tools-list] VMM - Video Virtual Hardware question



Hi Cole,
I am using upstream libvirt as well and the version is still 6005 so I guess this version is OK. I've already posted 2 patches - disk size & allocation bits (first one) and USB/PCI device information bits (second one) to this list and *may be* the first patch is needed to be applied for hunks of second patch to be applicable.

Also, do you think we should change condition here to to be equals or greater than rather than just greater than?

Thansk,
Michal

----- Original Message -----
From: "Cole Robinson" <crobinso redhat com>
To: "Michal Novotny" <minovotn redhat com>
Cc: "virt-tools-list" <virt-tools-list redhat com>
Sent: Wednesday, August 5, 2009 4:28:15 PM GMT +01:00 Amsterdam / Berlin / Bern / Rome / Stockholm / Vienna
Subject: Re: [virt-tools-list] VMM - Video Virtual Hardware question

On 08/05/2009 08:36 AM, Michal Novotny wrote:
> Hi,
> I've been digging some of virt-manager code because of USB/PCI devices bits so I was exploring addhardware.py . There is a condition to show that libvirt doesn't support Video hardware if the version is not greater then 6005 (libvirt 0.6.5). I've been testing this on 0.6.5 version as well (by doing a small hack in my VMM local installation) and the SystemRescue CD in mounted CD-ROM drive was showing different video devices here (ie. Cirrus logic, VMWare video device and something else) when doing changes in that. Isn't is possible the condition here is not right and it should be:
> 
>        add_hw_option("Video", "video-display", PAGE_VIDEO,
>                       libvirt.getVersion() >= 6005,
>                       _("Libvirt version does not support video devices."))
> 
> instead of:
> 
>        add_hw_option("Video", "video-display", PAGE_VIDEO,
>                       libvirt.getVersion() > 6005,
>                       _("Libvirt version does not support video devices."))
> 
> in addhardware.py (the condition on libvirt.getVersion() line should be equals or greater than rather than just greater than) ?
> 
> Thanks,
> Michal
> 

Yes, that change would be correct. I had originally meant to change it
when I pushed the original code (since I was using upstream libvirt).

Thanks,
Cole


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]