[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [virt-tools-list] problems with domain installation



On Fri, 11 Dec 2009, Cole Robinson wrote:

On 12/11/2009 03:52 AM, Tomas Macek wrote:
Hi, I'm using redhat enterprise 5.4 with newest redhat kvm/qemu packages
installed for testing purposes.
I'm trying to install debian lenny from ISO on the machine with only ssh access
using virt-install python script and the output is like this

--------------------------
[root localhost ~]# virt-install --connect qemu:///system -n fedora12 -f
~/fedora12.qcow2 -s 3 -r 128 --accelerate --network=bridge:br0 --hvm
--location
http://download.fedoraproject.org/pub/fedora/linux/releases/12/Fedora/i386/os/
--nographics -x console=/dev/ttyS0


Starting install...
Retrieving file .treeinfo...
| 1.4 kB     00:00
Retrieving file vmlinuz...
| 3.2 MB     00:00
Retrieving file initrd.img...
|  22 MB     00:06
Creating storage file...
| 3.0 GB     00:00
Creating domain...
|    0 B     00:00
Connected to domain fedora12
Escape character is ^]

Domain installation still in progress. You can reconnect to
the console to complete the installation process.

--------------------------

The problem is, that the fedora12 is created (can be seen with "virsh
list"), but
I'm unable to connect to the console using both "virsh console fedora12"
or
with minicom to /dev/pts/3 (I got the /dev/pts/3 from "virsh ttyconsole
fedora12" command).
The same was the result when I tried to install Fedora 12.

I need to run the installation from the command line and not from the X window
interface like virt-manager, but the only thing I see is always the "Escape
character is ^]" as the output.
I've spent a lot of time googling what I'm doing wrong, but the only replies
I've found was "... the vnc access is better, use it..." or that I should
redirect the installation console to serial device - I think I'm doing it with
the "-x console=/dev/ttyS0", so what's wrong?


As far as I know that should work. Is the VM crashing maybe? What
happens above after the domain creation, does the console just sit there
after 'Escape character is ^]' or does it exit immediately? If it exits,
something went wrong.

Yes, the console does only sit there and does nothing else. The only output from this was one character "?" written with black font with white background (sorry, my english is poor) - it is some special char and this "output" was after about 3 seconds. I was waiting for some other output for some minutes, but nothing else happened. The VM is not crashing IMHO, because I'm trying simultaneously connect using virt-manager (in X window) and it shows, that virtual machine spends some CPU time and memory. I can normally destroy it. And yes - this way I don't see anything, because of the "--nographics", so I'm not absolutely sure, what is going on in the virtual guest.

When you say you are unable to connect using virsh console, do you mean
it doesn't print anything or the command fails? If it fails, please post
the output.

The only output is in my original post, nothing else.

Strange is, that this behaviour is simillar to the debian installation over the internet. According to the debian's doc the debian should know "console=/dev/ttyS0" just like fedora, but the result is the same.

I spent on this 2 days searching the internet and testing (hope) everthing as far as I had invention...

Tomas


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]