[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [virt-tools-list] virt-install 0.400-3: cannot install

Cole Robinson wrote:
On 11/22/2009 02:04 PM, Gerry Reno wrote:
Gerry Reno wrote:
Cole Robinson wrote:
On 11/22/2009 01:20 PM, Gerry Reno wrote:
Cole Robinson wrote:
On 11/22/2009 01:12 AM, Gerry Reno wrote:

I'm trying to do a text-based install using virt-install 0.400-3 on a
ubuntu server 9.10 but it is refusing to install. Here is the form of
the command I'm using:

$ sudo -s
# virt-install -n "DOMAIN-1" --vcpus=4 --ram=2048 --disk

--accelerate --network=bridge:br0 --nographics
--extra-args="console=tty0 console=ttyS0,115200"

I've tried local, nfs, http for locations and it either says its
not an
installable distribution or I get a ValueError: Invalid install
location. But I can wget the iso with no problem using the same url.

Can anyone point me to what is wrong with my command line?

--location needs to point to an install tree, not an iso. You should
be able
to replace --location with --cdrom to make things work. This is
described in
the virt-install man page.


Ok, I just tried it replacing --location with --cdrom and it gives me
the exact same ValueError: Invalid install location Opening URL

Argh, yes. I was wrong about that, --cdrom also expects a top level
path. That should be fixed though, to just allow pointing to a cdrom
like you did.

So I nfs mounted the iso across the network and then passed the
mountpoint to --cdrom and this at least creates the domain but then it
just sits there at "Escape is ^]" and does not do anything else.

Is there something wrong with my console args?

If you boot off a cdrom, kernel args have no effect, since we have no
way to
pass them in to the cd. Extra args only work if you directly boot a
You should be able to try using


which will do a direct kernel boot, allowing extra args.

- Cole

I think our posts just crossed. I try this and get back...

Ok, that location is working but the guest network is behaving painfully
slow. I have a 20Mbps service but the install file retrieval is going
like 56kbps. Ugh...

I think kernel.org gets a ton of traffic, it might be worth trying another mirror.

- Cole
I think it is past that point and when it is retrieving all the packages from us.archive.ubuntu.com. Either that site is really slow or the guest network is slow. I'll have to see which after the install completes. Thanks for getting this working for me.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]