[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [virt-tools-list] virt-install 0.400-3: cannot install



Gerry Reno wrote:
Gerry Reno wrote:
It finally finished the install and rebooted but now it appears that the guest is not booting. So need to investigate why it doesn't boot up. No console output at all after I start the guest. I dumped the xml and the boot dev is now "hd" and the path to the image is correct.

-Gerry
Ok, I reran the install and got the exact same result. No bootup or no console output at least.

Here is the process line:
root 23068 1 0 20:46 ? 00:00:02 /usr/bin/kvm -S -M pc-0.11 -m 2048 -smp 4 -name DOMAIN-1 -uuid b1620075-a0ba-1246-fd67-1243c20870a6 -nographic -monitor unix:/var/run/libvirt/qemu/DOMAIN-1.monitor,server,nowait -boot c -drive file=/var/lib/libvirt/images/DOMAIN-1.img,if=ide,index=0,boot=on -net nic,macaddr=54:52:00:4b:f1:a6,vlan=0,name=nic.0 -net tap,fd=17,vlan=0,name=tap.0 -serial pty -parallel none -usb

I see it has both -monitor and -serial.  Does that make any difference?

-Gerry
I tried running the command directly and here is what it outputs:
TUNGETIFF ioctl() failed: Bad file descriptor
TUNSETOFFLOAD ioctl() failed: Bad file descriptor
char device redirected to /dev/pts/1

I checked both the image file and the .monitor file and both are there and readable so I don't understand what file it is complaining about.

-Gerry


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]