[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [virt-tools-list] virt-install 0.400-3: cannot install



Gerry Reno wrote:
Cole Robinson wrote:
On 11/22/2009 09:57 PM, Gerry Reno wrote:
Gerry Reno wrote:
Gerry Reno wrote:
It finally finished the install and rebooted but now it appears that
the guest is not booting.  So need to investigate why it doesn't boot
up.  No console output at all after I start the guest.  I dumped the
xml and the boot dev is now "hd" and the path to the image is correct.

-Gerry
Ok, I reran the install and got the exact same result.  No bootup or
no console output at least.


Just because you passed those kernel command line options in for install
doesn't mean they will stick for the life of the VM. You will need to find a
way to edit the grub.conf in the guest to get bootup output, and then
/etc/inittab to start a TTY on the serial line.

I thought I had done this because I added the console args to the kernel line during the installation screens so I assumed it would generate a grub.cfg(grub2) using them. I guess that still wasn't enough.

You'll either need to set up temporary graphical access, find the IP of the VM and use ssh, or some way to kernel boot into rescue mode (or hack up your own
boot.iso to append custom kernel args).
Yes, I need to figure out how to get a text-based rescue session running for the VM.

Here is the process line:
root     23068     1  0 20:46 ?        00:00:02 /usr/bin/kvm -S -M
pc-0.11 -m 2048 -smp 4 -name DOMAIN-1 -uuid
b1620075-a0ba-1246-fd67-1243c20870a6 -nographic -monitor
unix:/var/run/libvirt/qemu/DOMAIN-1.monitor,server,nowait -boot c
-drive
file=/var/lib/libvirt/images/DOMAIN-1.img,if=ide,index=0,boot=on -net
nic,macaddr=54:52:00:4b:f1:a6,vlan=0,name=nic.0 -net
tap,fd=17,vlan=0,name=tap.0 -serial pty -parallel none -usb

I see it has both -monitor and -serial. Does that make any difference?

-Gerry
I tried running the command directly and here is what it outputs:
TUNGETIFF ioctl() failed: Bad file descriptor
TUNSETOFFLOAD ioctl() failed: Bad file descriptor
char device redirected to /dev/pts/1


You can't run the generated command directly because libvirtd sets up things
like tap devices before running the guest.

I checked both the image file and the .monitor file and both are there
and readable so I don't understand what file it is complaining about.


It's complaining about the tapfd, which isn't present because libvirt usually
takes care of it.
Ok, understand that.  Thanks.


- Cole


I tried starting the VM in graphical env with virt-manager. The VM never starts and throws this error:
Traceback (most recent call last):
File "/usr/share/virt-manager/virtManager/engine.py", line 493, in run_domain
   vm.startup()
 File "/usr/share/virt-manager/virtManager/domain.py", line 573, in startup
   self.vm.create()
 File "/usr/lib64/python2.6/site-packages/libvirt.py", line 287, in create
   if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: internal error Domain DOMAIN-1 didn't show up

So it doesn't look like this is a guest distro issue. How can I track down what is wrong?

-Gerry


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]