[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [virt-tools-list] Problem creating vm's with virt-manager 0.7.0



On 10/15/2009 03:14 PM, Joseph Shraibman wrote:
> 
> On a CentOS 5.3 machine (with qemu 0.9.1, kvm-84) I had been using 
> virt-manager 0.6.0 but had recently upgraded to 0.7.0 (I tried 0.8.0 but 
> found that unusable). 

How was it 'unusable'? If you were getting errors, please post your
~/.virt-manager/virt-manager.log (either here, or in bugzilla:
http://virt-manager.et.redhat.com/page/BugReporting)

I also built a new virt-install 0.500.0. I'm not
> sure what I had before since there is no --version command to virt-install.
> 
> I created a new vm but when I tried to start it I got errors like this:
> 
> Unable to complete install 'libvirt.libvirtError internal error unable 
> to start guest: qemu: unknown parameter 'fmt' in 
> 'file=/var/lib/libvirt/images/f11-test01.img,if=virtio,index=0,fmt='
> 

Sounds like libvirt should be checking to make sure the 'fmt' parameter
is actually supported by qemu, and not passing it otherwise. This would
require a libvirt update though.

> Traceback (most recent call last):
>    File "/usr/local/share/virt-manager/virtManager/create.py", line 
> 1485, in do_install
>      dom = guest.start_install(False, meter = meter)
>    File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 628, 
> in start_install
>      return self._do_install(consolecb, meter, removeOld, wait)
>    File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 726, 
> in _do_install
>      self.domain = self.conn.createLinux(install_xml, 0)
>    File "/usr/lib64/python2.4/site-packages/libvirt.py", line 974, in 
> createLinux
>      if ret is None:raise libvirtError('virDomainCreateLinux() failed', 
> conn=self)
> libvirtError: internal error unable to start guest: qemu: unknown 
> parameter 'fmt' in 
> 'file=/var/lib/libvirt/images/f11-test01.img,if=virtio,index=0,fmt='
> 
> I got similar errors if I just created the vm and tried to start it with 
> virsh.  I solved the problem by removing the following from the 
> /etc/libvirt/qemu/xxxx.xml file:
> 
>    <driver name='qemu'/>
> 
> 
> I've also found that booting the new machines with an .iso in the the 
> virtual hard drive resulted in machines that were crawling on startup. I 
> tried with ubuntu and fedora live cd images. I had previously installed 
> virtual machines by booting from .iso images so I don't know what the 
> problem could be.  Those machines still start and run without problems. 
> I never upgraded qemu or kvm, the only thing that changed was 
> virt-manager.  I diff'ed xml files between the old and new vm's and 
> besides the <driver> element the only thing different was <input 
> type='tablet' bus='usb'/>.  I removed that but the vm's still crawl 
> after booting the kernel and eventually stall.  Could this be 
> virt-manager's fault somehow?
> 

No idea what could be causing things to crawl if that is the only XML
diff. Did you also update libvirt? If so, libvirt could be generating a
different qemu command line behind the scenes which could be causing
issues (though unlikely). You can check the generated qemu command line
in /var/log/libvirt/qemu/<vmname>.log

Thanks,
Cole


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]