[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [virt-tools-list] virt-install with --location=http:// fails to fetch and install debian 64 domU



OK, I thought it would work to use the standard kernels i.e. not the specific netboot/xen directory, and that they would have Xen domU support.
However, DebianLenny 32, DebianTesting 32/64, and UbuntuLTS 32/64 seem to have domU support in netboot/xen. So that's all fine, but unfortunately no Lenny64.

Sorry for creating this ticket.

On Aug 6, 2010, at 5:21 PM, Cole Robinson wrote:

> On 08/06/2010 08:28 AM, Carl Bachman Kharazmi wrote:
>> Hi,
>> 
>> virt-install -n backup -r 256 --os-type=linux --os-variant=debianlenny
>> --vcpus=2 -p
>> --location=http://ftp.us.debian.org/debian/dists/lenny/main/installer-amd64/
>> --disk path=/dev/guest/stsbackup,cache=none --disk path=/dev/sdd,cache=none -b
>> xenbr1 -m RANDOM --vnc -k sv --prompt -d
>> 
>> Fails to install a debian 64 domU.
>> 
>> [root virtual-int-2 ~]# virt-install -n backup -r 256 --os-type=linux
>> --os-variant=debianlenny --vcpus=2 -p
>> --location=http://ftp.us.debian.org/debian/dists/lenny/main/installer-amd64/
>> --disk path=/dev/guest/stsbackup,cache=none --disk
>> path=/dev/sdd,cache=none -b xenbr1 -m RANDOM --vnc -k sv --prompt -d
>> Fri, 06 Aug 2010 13:45:48 DEBUG    Requesting libvirt URI default
>> Fri, 06 Aug 2010 13:45:48 DEBUG    Received libvirt URI 'xen:///'
>> Fri, 06 Aug 2010 13:45:48 DEBUG    Requesting virt method 'xen'
>> Fri, 06 Aug 2010 13:45:48 DEBUG    Received virt method 'xen'
>> Fri, 06 Aug 2010 13:45:48 DEBUG    Hypervisor name is 'xen'
>> Fri, 06 Aug 2010 13:45:48 DEBUG    parse_disk: returning
>> ('/dev/guest/stsbackup', None, None, 'disk', None, False, False, None,
>> True, 'none')
>> Fri, 06 Aug 2010 13:45:48 DEBUG    Setting size for existing storage to '5.0'
>> Fri, 06 Aug 2010 13:45:48 DEBUG    Detected storage as type 'block'
>> Fri, 06 Aug 2010 13:45:48 DEBUG    Setting size for existing storage to '5.0'
>> Fri, 06 Aug 2010 13:45:48 DEBUG    Detected storage as type 'block'
>> Fri, 06 Aug 2010 13:45:48 DEBUG    Setting size for existing storage to '5.0'
>> Fri, 06 Aug 2010 13:45:48 DEBUG    Detected storage as type 'block'
>> Fri, 06 Aug 2010 13:45:48 DEBUG    parse_disk: returning ('/dev/sdd',
>> None, None, 'disk', None, False, False, None, True, 'none')
>> Fri, 06 Aug 2010 13:45:48 DEBUG    Setting size for existing storage
>> to '232.830643654'
>> Fri, 06 Aug 2010 13:45:48 DEBUG    Detected storage as type 'block'
>> Fri, 06 Aug 2010 13:45:48 DEBUG    Setting size for existing storage
>> to '232.830643654'
>> Fri, 06 Aug 2010 13:45:48 DEBUG    Detected storage as type 'block'
>> Fri, 06 Aug 2010 13:45:48 DEBUG    Setting size for existing storage
>> to '232.830643654'
>> Fri, 06 Aug 2010 13:45:48 DEBUG    Detected storage as type 'block'
>> Fri, 06 Aug 2010 13:45:48 DEBUG    DistroInstaller location is a network source.
>> 
>> 
>> Starting install...
>> Fri, 06 Aug 2010 13:45:49 DEBUG    Attempting to detect distro:
>> Fri, 06 Aug 2010 13:45:49 DEBUG    HTTP hasFile: didn't find
>> http://ftp.us.debian.org/debian/dists/lenny/main/installer-amd64/.treeinfo
>> Fri, 06 Aug 2010 13:45:50 DEBUG    HTTP hasFile: didn't find
>> http://ftp.us.debian.org/debian/dists/lenny/main/installer-amd64/Fedora
>> Fri, 06 Aug 2010 13:45:50 DEBUG    HTTP hasFile: didn't find
>> http://ftp.us.debian.org/debian/dists/lenny/main/installer-amd64/Server
>> Fri, 06 Aug 2010 13:45:50 DEBUG    HTTP hasFile: didn't find
>> http://ftp.us.debian.org/debian/dists/lenny/main/installer-amd64/Client
>> Fri, 06 Aug 2010 13:45:51 DEBUG    HTTP hasFile: didn't find
>> http://ftp.us.debian.org/debian/dists/lenny/main/installer-amd64/RedHat
>> Fri, 06 Aug 2010 13:45:54 DEBUG    HTTP hasFile: didn't find
>> http://ftp.us.debian.org/debian/dists/lenny/main/installer-amd64/CentOS
>> Fri, 06 Aug 2010 13:45:55 DEBUG    HTTP hasFile: didn't find
>> http://ftp.us.debian.org/debian/dists/lenny/main/installer-amd64/SL
>> Fri, 06 Aug 2010 13:46:00 DEBUG    HTTP hasFile: didn't find
>> http://ftp.us.debian.org/debian/dists/lenny/main/installer-amd64/directory.yast
>> Fri, 06 Aug 2010 13:46:00 DEBUG    Fetching URI:
>> http://ftp.us.debian.org/debian/dists/lenny/main/installer-amd64/current/images/MANIFEST
>> Fri, 06 Aug 2010 13:46:01 DEBUG    Saved file to
>> /var/lib/xen/virtinst-MANIFEST.Gr1dJ3
>> Retrieving file MANIFEST...
>>   | 1.3 kB     00:00
>> Fri, 06 Aug 2010 13:46:01 DEBUG    Detected a Debian distro
>> Fri, 06 Aug 2010 13:46:01 DEBUG    HTTP hasFile: didn't find
>> http://ftp.us.debian.org/debian/dists/lenny/main/installer-amd64/current/images/netboot/xen/vmlinuz
>> Fri, 06 Aug 2010 13:46:01 ERROR    Couldn't find xen kernel for Debian tree.
>> Fri, 06 Aug 2010 13:46:01 DEBUG    Traceback (most recent call last):
>>  File "/usr/sbin/virt-install", line 751, in main
>>    start_time, guest.start_install)
>>  File "/usr/sbin/virt-install", line 813, in do_install
>>    dom = install_func(conscb, progresscb, wait=(not wait))
>>  File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 539,
>> in start_install
>>    self._prepare_install(meter)
>>  File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 594,
>> in _prepare_install
>>    meter = meter)
>>  File "/usr/lib/python2.4/site-packages/virtinst/DistroInstaller.py",
>> line 245, in prepare
>>    self._prepare_kernel_and_initrd(guest, distro, meter)
>>  File "/usr/lib/python2.4/site-packages/virtinst/DistroInstaller.py",
>> line 194, in _prepare_kernel_and_initrd
>>    type=self.os_type, distro=distro)
>>  File "/usr/lib/python2.4/site-packages/virtinst/OSDistro.py", line
>> 156, in acquireKernel
>>    scratchdir, type, distro)
>>  File "/usr/lib/python2.4/site-packages/virtinst/OSDistro.py", line
>> 142, in _acquireMedia
>>    return (store.acquireKernel(guest, fetcher, progresscb),
>>  File "/usr/lib/python2.4/site-packages/virtinst/OSDistro.py", line
>> 253, in acquireKernel
>>    raise RuntimeError(_("Couldn't find %(type)s kernel for "
>> RuntimeError: Couldn't find xen kernel for Debian tree.
>> 
>> I reported a bug which describe more details concerning this:
>> https://bugzilla.redhat.com/show_bug.cgi?id=621890
>> 
>> http://ftp.uk.debian.org/debian/dists/lenny/main/installer-i386/current/images/MANIFEST
>> seem to include path to xen kernel, while:
>> http://ftp.uk.debian.org/debian/dists/lenny/main/installer-amd64/current/images/MANIFEST
>> does not.
>> 
>> Are there any option to virt-install to set the directory which it
>> should use to retrieve kernel, or any other workaround for this
>> problem?
>> 
> 
> I just commented in your bug report. According to:
> 
> http://wiki.debian.org/Xen
> 
> lenny doesn't support 64 bit xen domU install.
> 
> - Cole



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]