[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[virt-tools-list] AttributeError: type object 'VirtualAudio' has no attribute 'MODEL_DEFAULT' -- virt manager 0.8.4 requires virtinst 0.500.3 but then fails to open guest windows



I have Centos with the latest patches running XEN dom0 and several RHEL guests.
In the original installation the Virt manager happily opened the guests using the "Open" option on the guest that appears in the virt Manager.

I then applied some patches from regular yum update, I've tried downloading and manually installing Virt Manager and VirtInst and now I have the problem that the Virt Manager tries to open the guest window and gets:

Traceback (most recent call last):
  File "/usr/local/share/virt-manager/virtManager/engine.py", line 571, in show_details
    details = vmmDetails(self.get_config(), con.get_vm(uuid), self)
  File "/usr/local/share/virt-manager/virtManager/details.py", line 196, in __init__
    self.init_details()
  File "/usr/local/share/virt-manager/virtManager/details.py", line 565, in init_details
    uihelpers.build_sound_combo(self.vm, sound_dev, no_default=no_default)
  File "/usr/local/share/virt-manager/virtManager/uihelpers.py", line 134, in build_sound_combo
    if m == virtinst.VirtualAudio.MODEL_DEFAULT and no_default:
AttributeError: type object 'VirtualAudio' has no attribute 'MODEL_DEFAULT'

System:

Last login: Tue Aug 10 16:34:55 2010
xm [root platformvm0 ~]# xm info
host                   : platformvm0
release                : 2.6.18-194.8.1.el5xen
version                : #1 SMP Thu Jul 1 19:41:05 EDT 2010
machine                : x86_64
nr_cpus                : 4
nr_nodes               : 1
sockets_per_node       : 1
cores_per_socket       : 4
threads_per_core       : 1
cpu_mhz                : 2000
hw_caps                : bfebfbff:20000800:00000000:00000140:0004e33d:00000000:00000001
total_memory           : 4093
free_memory            : 0
node_to_cpu            : node0:0-3
xen_major              : 3
xen_minor              : 1
xen_extra              : .2-194.8.1.el5
xen_caps               : xen-3.0-x86_64 xen-3.0-x86_32p
xen_pagesize           : 4096
platform_params        : virt_start=0xffff800000000000
xen_changeset          : unavailable
cc_compiler            : gcc version 4.1.2 20080704 (Red Hat 4.1.2-48)
cc_compile_by          : mockbuild
cc_compile_domain      : centos.org
cc_compile_date        : Thu Jul  1 18:56:55 EDT 2010
xend_config_format     : 2


Config file:

name = "evossc-standalone_3.7.0.0_18751_VM1"
uuid = "cdb7ab03-c144-6164-c632-b904575c31d4"
maxmem = 3500
memory = 3500
vcpus = 2
bootloader = "/usr/bin/pygrub"



vfb = [ "type=vnc,vncunused=0,vncdisplay=5" ]
disk = [ "tap:aio:/home/xen/evossc-nodeA/evossc-standalone_3.7.0.0_18751_VM1.img,xvda,w" ]
vif = [ "mac=00:16:3e:64:66:62,bridge=xenbr0,script=vif-bridge", "mac=00:16:3e:65:66:63,bridge=xenbr1,script=vif-bridge" ]

Using these two packages, manually compiled and installed...
virt-manager-0.8.4
virtinst-0.500.3

Any clues on what I need to do on the host or xen guest configuration file?  I've tried added a vnc server configuration to the guest config file but this just says connection refused.

Mike


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]