[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [virt-tools-list] virt-install unknown HTTP error code



On Mon, Dec 20, 2010 at 01:04:33PM -0800, Neil Baylis wrote:
> On 12/19/2010 09:04 AM, Richard W.M. Jones wrote:
> >On Fri, Dec 17, 2010 at 01:46:49PM -0800, Neil Baylis wrote:
> >>I get the following error when attempting to run virt-install:
> >>      if ret is None:raise libvirtError('virConnectOpenAuth() failed')
> >>libvirtError: got unknown HTTP error code 382254624
> >
> >It seems to be an error from libvirt, so what happens when
> >you do the same command after:
> >
> >export LIBVIRT_DEBUG=1
> >
> 
> Thanks. Here's the result when I set the DEBUG flag as suggested:
>
> kaan-20:~# export LIBVIRT_DEBUG=1
> kaan-20:~# virt-install
> 04:53:20.842: debug : virInitialize:336 : register drivers
> 04:53:20.842: debug : virRegisterDriver:837 : registering Test as driver 0
> 04:53:20.842: debug : virRegisterNetworkDriver:675 : registering
> Test as network driver 0
> 04:53:20.842: debug : virRegisterInterfaceDriver:706 : registering
> Test as interface driver 0
> 04:53:20.842: debug : virRegisterStorageDriver:737 : registering
> Test as storage driver 0
> 04:53:20.842: debug : virRegisterDeviceMonitor:768 : registering
> Test as device driver 0
> 04:53:20.842: debug : virRegisterSecretDriver:799 : registering Test
> as secret driver 0
> 04:53:20.842: debug : xenHypervisorInit:1961 : Using new hypervisor
> call: 40001
> 
> 04:53:20.842: debug : xenHypervisorInit:2066 : Failed to find any
> Xen hypervisor method
> 
> 04:53:20.842: debug : virRegisterDriver:837 : registering Xen as driver 1
> 04:53:20.842: debug : virRegisterDriver:837 : registering OPENVZ as driver 2
> 04:53:20.843: debug : vboxRegister:109 : VBoxCGlueInit failed, using
> dummy driver
> 04:53:20.843: debug : virRegisterDriver:837 : registering VBOX as driver 3
> 04:53:20.843: debug : virRegisterNetworkDriver:675 : registering
> VBOX as network driver 1
> 04:53:20.843: debug : virRegisterStorageDriver:737 : registering
> VBOX as storage driver 1
> 04:53:20.843: debug : virRegisterDriver:837 : registering remote as driver 4
> 04:53:20.843: debug : virRegisterNetworkDriver:675 : registering
> remote as network driver 2
> 04:53:20.843: debug : virRegisterInterfaceDriver:706 : registering
> remote as interface driver 1
> 04:53:20.843: debug : virRegisterStorageDriver:737 : registering
> remote as storage driver 2
> 04:53:20.843: debug : virRegisterDeviceMonitor:768 : registering
> remote as device driver 1
> 04:53:20.843: debug : virRegisterSecretDriver:799 : registering
> remote as secret driver 1
> 04:53:21.044: debug : virConnectOpenAuth:1337 : name=(null),
> auth=0x7fffdfeaa1c0, flags=0
> 04:53:21.051: debug : do_open:1108 : no name, allowing driver auto-select
> 04:53:21.051: debug : do_open:1116 : trying driver 0 (Test) ...
> 04:53:21.051: debug : do_open:1122 : driver 0 Test returned DECLINED
> 04:53:21.051: debug : do_open:1116 : trying driver 1 (Xen) ...
> 04:53:21.051: debug : xenUnifiedOpen:324 : Trying hypervisor sub-driver
> 04:53:21.051: debug : xenUnifiedOpen:327 : Activated hypervisor sub-driver
> 04:53:21.051: debug : xenUnifiedOpen:335 : Trying XenD sub-driver
> 04:53:21.053: debug : xenUnifiedOpen:406 : Failed to activate a
> mandatory sub-driver
> 04:53:21.054: debug : do_open:1122 : driver 1 Xen returned ERROR
> 04:53:21.054: debug : virUnrefConnect:259 : unref connection 0x29b7d50 1
> 04:53:21.054: debug : virReleaseConnect:216 : release connection 0x29b7d50
> ERROR    got unknown HTTP error code -538278480
> Traceback (most recent call last):
>   File "/usr/bin/virt-install", line 943, in <module>
>     main()
>   File "/usr/bin/virt-install", line 715, in main
>     conn = cli.getConnection(options.connect)
>   File "/usr/lib/pymodules/python2.6/virtinst/cli.py", line 162, in
> getConnection
>     conn = open_connection(connect)
>   File "/usr/lib/pymodules/python2.6/virtinst/cli.py", line 177, in
> open_connection
>     open_flags)
>   File "/usr/lib/python2.6/dist-packages/libvirt.py", line 111, in openAuth
>     if ret is None:raise libvirtError('virConnectOpenAuth() failed')
> libvirtError: got unknown HTTP error code -538278480
> kaan-20:~# xm list
> Name                                        ID   Mem VCPUs
> State Time(s)
> Domain-0                                     0  1024     1
> r----- 15420.9
> kaan-20:~#

It's not clear at all what's going on, except that the error comes
from xend, and the error number really makes no sense at all.

You would have to find out what libvirt and xend are sending to each
other.  'strace' might help.

Also please don't send me email directly.

Rich.

-- 
Richard Jones, Virtualization Group, Red Hat http://people.redhat.com/~rjones
Libguestfs lets you edit virtual machines.  Supports shell scripting,
bindings from many languages.  http://et.redhat.com/~rjones/libguestfs/
See what it can do: http://et.redhat.com/~rjones/libguestfs/recipes.html


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]