[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [virt-tools-list] why -no-kvm flag?



Oh, and I forgot to say that this is for a newly created VM.

Existing VMs are started with:
qemu      5878 94.6  0.9 3311336 39252 ?       R    11:19   0:07 /usr/bin/qemu-kvm -S -M pc-0.11 -enable-kvm -m 2048 -smp 4,sockets=4,cores=1,threads=1 -name fc12 -uuid 464bbaa8-5ea4-1fb9-b744-c9d2c0666b30 -nodefaults -chardev socket,id=monitor,path=/var/lib/libvirt/qemu/fc12.monitor,server,nowait -mon chardev=monitor,mode=readline -boot c -drive file=/var/lib/libvirt/images/pv-work1.img,if=none,id=drive-virtio-disk0,boot=on,format=raw -device virtio-blk-pci,bus=pci.0,addr=0x4,drive=drive-virtio-disk0,id=virtio-disk0 -drive file=/tmp/virdisk.img,if=none,id=drive-virtio-disk1,format=raw -device virtio-blk-pci,bus=pci.0,addr=0x5,drive=drive-virtio-disk1,id=virtio-disk1 -drive file=/root/Desktop/SUSE_SLES-11-0-0-DVD1.iso,if=none,media=cdrom,id=drive-ide0-1-0 -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -device rtl8139,vlan=0,id=net0,mac=52:54:00:40:44:8b,bus=pci.0,addr=0x6 -net tap,fd=21,vlan=0,name=hostnet0 -chardev file,id=serial0,path=/var/log/gst-fc12 -device isa-serial,chardev=serial0 -usb -vnc 127.0.0.1:1 -vga cirrus -device ES1370,id=sound0,bus=pci.0,addr=0x7 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x3

but they fail to start due to not being able to find a boot device

Dan

On Tue, Feb 9, 2010 at 11:03 AM, Dan Bar Dov <bardov gmail com> wrote:
I tried, but for whatever reason it seems virsh cannot connect - here's what I get:

[dan gennady-dt ~]$ virsh dumpxml zzzzz
error: failed to get domain 'zzzzz'
error: Domain not found: no domain with matching name 'zzzzz'

[dan gennady-dt ~]$ virsh list
 Id Name                 State
----------------------------------

[dan gennady-dt ~]$ ps aux | grep qemu
qemu      3741  6.2  0.6 3311476 26604 ?       S    10:52   0:00 /usr/bin/qemu-system-x86_64 -S -M pc-0.12 -no-kvm -m 2048 -smp 2,sockets=2,cores=1,threads=1 -name zzzzz -uuid de43e524-21a7-0131-d7df-8c9d2b56e570 -nodefaults -chardev socket,id=monitor,path=/var/lib/libvirt/qemu/zzzzz.monitor,server,nowait -mon chardev=monitor,mode=readline -boot c -drive file=/var/lib/libvirt/images/zzzzz.img,if=none,id=drive-ide0-0-0,boot=on,format=raw -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive if=none,media=cdrom,id=drive-ide0-1-0 -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -device rtl8139,vlan=0,id=net0,mac=52:54:00:7c:ec:38,bus=pci.0,addr=0x4 -net tap,fd=19,vlan=0,name=hostnet0 -chardev pty,id=serial0 -device isa-serial,chardev=serial0 -usb -device usb-tablet,id=input0 -vnc 127.0.0.1:0 -k en-us -vga cirrus -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x3

BTW, I've also updated to:
libvirt-0.7.6-1.fc12.x86_64.rpm
libvirt-client-0.7.6-1.fc12.x86_64.rpm
libvirt-python-0.7.6-1.fc12.x86_64.rpm

Dan


On Mon, Feb 8, 2010 at 9:40 PM, Cole Robinson <crobinso redhat com> wrote:
On 02/08/2010 12:30 PM, Dan Bar Dov wrote:
> I've upgraded qemu-kvm to 0.12.2, (as well as virt-manager: 0.8.2, and
> virtinst 0.500.1) and noticed
> all virtual machines are extremely slow.
> I noticed the qemu is now started using /usr/bin/qemu-system-x86_64 with
> -no-kvm switch.
>
> I'm guessing this is working in full emulation mode and no hardware support,
> which explains
> the slowness.
>
> What affects the selection of the -no-kvm switch? What do I need to do to
> get it working
> properly again?
>

Are these newly created VMs, or existing ones that worked fine before
the update? Can you post the output of 'virsh dumpxml $vmname' for an
affected VM?

Thanks,
Cole




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]