[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [virt-tools-list] [libvirt] libvirtError: internal error unknown boot device 'floppy'



> Date: Wed, 14 Jul 2010 09:37:41 -0400
> From: crobinso redhat com
> To: johnlumby hotmail com
> CC: libvir-list redhat com; virt-tools-list redhat com
> Subject: Re: [libvirt] libvirtError: internal error unknown boot device 'floppy'
>
> On 07/13/2010 09:30 PM, John Lumby wrote:
> > Hello. I believe I've found a bug in libvirtd but not sure.
> >
>
> Can you provide the full output of the virt-install command with the --debug flag?
>  - Cole
 

Below is what it wrote to my  ~/.virtinst/virt-install.log

(without the --debug flag but according to the man page it's the same debug output)


Interesting to see that it generated what looks to be a good .xml but it did not put that into my libvirt/qemu directory.
Seems it just does not know about booting from a floppy?


If you need something else let me know.



John


[Tue, 13 Jul 2010 19:12:16 virt-install 30445] DEBUG (cli:192) Launched with command line:
/usr/local/bin/virt-install --connect qemu:///system --name=RH7win2k --ram=392 --cpuset=0 --description=wni 2k on RH7 disk on usb, nat network --import --network=network=default --virt-type=kqemu --accelerate --vnc --vncport=5905 --video=cirrus --disk=/mnt/soltbakp/commonfiles/win2k_boot.floppage,device=floppy --disk=/dev/sdc,device=disk --os-type=windows --os-variant=win2k
[Tue, 13 Jul 2010 19:12:16 virt-install 30445] DEBUG (cli:216) Requesting libvirt URI qemu:///system
[Tue, 13 Jul 2010 19:12:16 virt-install 30445] DEBUG (cli:218) Received libvirt URI qemu:///system
[Tue, 13 Jul 2010 19:12:16 virt-install 30445] DEBUG (virt-install:473) Requesting virt method 'default', hv type 'kqemu'.
[Tue, 13 Jul 2010 19:12:16 virt-install 30445] DEBUG (virt-install:795) Received virt method 'hvm'
[Tue, 13 Jul 2010 19:12:16 virt-install 30445] DEBUG (virt-install:796) Hypervisor name is 'kqemu'
[Tue, 13 Jul 2010 19:12:16 virt-install 30445] DEBUG (virt-install:330) parse_disk: returning {'format': None, 'bus': None, 'readOnly': False, 'volInstall': None, 'path': '/mnt/soltbakp/commonfiles/win2k_boot.floppage', 'device': 'floppy', 'volName': None, 'conn': <libvirt.virConnect instance at 0x84e6f6c>, 'size': None, 'driverCache': None, 'shareable': False, 'sparse': True}
[Tue, 13 Jul 2010 19:12:16 virt-install 30445] DEBUG (virt-install:330) parse_disk: returning {'format': None, 'bus': None, 'readOnly': False, 'volInstall': None, 'path': '/dev/sdc', 'device': 'disk', 'volName': None, 'conn': <libvirt.virConnect instance at 0x84e6f6c>, 'size': None, 'driverCache': None, 'shareable': False, 'sparse': True}
[Tue, 13 Jul 2010 19:12:17 virt-install 30445] DEBUG (Guest:1002) Generated install XML: None required
[Tue, 13 Jul 2010 19:12:17 virt-install 30445] DEBUG (Guest:1020) Generated boot XML:
<domain type='kqemu'>
<name>RH7win2k</name>
<currentMemory>401408</currentMemory>
<memory>401408</memory>
<uuid>1ce5803c-69f9-5e94-7905-4ae6227ff7c5</uuid>
<description>wni 2k on RH7 disk on usb, nat network</description>
<os>
<type arch='i686'>hvm</type>
<boot dev='floppy'/>
</os>
<features>
<acpi/><apic/><pae/>
</features>
<clock offset="localtime"/>
<on_poweroff>destroy</on_poweroff>
<on_reboot>restart</on_reboot>
<on_crash>restart</on_crash>
<vcpu cpuset='0'>1</vcpu>
<devices>
<emulator>/usr/local/bin/qemu</emulator>
<disk type='file' device='floppy'>
<driver name='qemu'/>
<source file='/mnt/soltbakp/commonfiles/win2k_boot.floppage'/>
<target dev='fda' bus='fdc'/>
</disk>
<disk type='block' device='disk'>
<driver name='qemu'/>
<source dev='/dev/sdc'/>
<target dev='hda' bus='ide'/>
</disk>
<interface type='network'>
<source network='default'/>
<mac address='52:54:00:6d:d3:bd'/>
</interface>
<input type='tablet' bus='usb'/>
<graphics type='vnc' port='5905' keymap='en-us'/>
<console type='pty'/>
<video>
<model type='cirrus'/>
</video>
</devices>
</domain>

[Tue, 13 Jul 2010 19:12:17 virt-install 30445] ERROR (virt-install:946) internal error unknown boot device 'floppy'
[Tue, 13 Jul 2010 19:12:17 virt-install 30445] ERROR (virt-install:1039) internal error unknown boot device 'floppy'
Traceback (most recent call last):
File "/usr/local/bin/virt-install", line 1033, in <module>
main()
File "/usr/local/bin/virt-install", line 915, in main
start_time, guest.start_install)
File "/usr/local/bin/virt-install", line 957, in do_install
dom = install_func(conscb, progresscb, wait=(not wait))
File "/usr/local/lib/python2.6/site-packages/virtinst/Guest.py", line 972, in start_install
return self._do_install(consolecb, meter, removeOld, wait)
File "/usr/local/lib/python2.6/site-packages/virtinst/Guest.py", line 1037, in _do_install
"install")
File "/usr/local/lib/python2.6/site-packages/virtinst/Guest.py", line 1021, in _create_guest
self.domain = self.conn.defineXML(final_xml)
File "/usr/local/lib/python2.6/site-packages/libvirt.py", line 1224, in defineXML
if ret is None:raise libvirtError('virDomainDefineXML() failed', conn=self)
libvirtError: internal error unknown boot device 'floppy'
 




Enter for a chance to get your town photo on Bing.ca! Submit a Photo Now!

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]