[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[virt-tools-list] Trouble setting Virtual Network



I'm having trouble setting virtual network.
The debug log is the following:

--XML dump of the network I'm trying to set--

virsh # net-dumpxml net0
<network>
  <name>net0</name>
  <uuid>bb909289-700a-87f8-c075-910209d1a2e3</uuid>
  <bridge name='virbr0' stp='on' delay='0' />
  <ip address='192.168.100.1' netmask='255.255.255.0'>
    <dhcp>
      <range start='192.168.100.128' end='192.168.100.254' />
    </dhcp>
  </ip>
</network>

--Error message when I try to startup the network--

virsh # net-start net0
17:04:48.570: debug : virNetworkLookupByName:5884 : conn=0x9d82658, name=net0
17:04:48.570: debug : remoteIO:9802 : Do proc=46 serial=3 length=36 wait=(nil)
17:04:48.570: debug : remoteIO:9877 : We have the buck 46 0x9d96488 0x9d96488
17:04:48.570: debug : remoteIODecodeMessageLength:9233 : Got length,
now need 80 total (76 more)
17:04:48.570: debug : remoteIOEventLoop:9728 : Giving up the buck 46
0x9d96488 (nil)
17:04:48.570: debug : remoteIO:9908 : All done with our call 46 (nil) 0x9d96488
17:04:48.570: debug : virNetworkCreate:6140 : network=0x9d96488
17:04:48.570: debug : remoteIO:9802 : Do proc=39 serial=4 length=52 wait=(nil)
17:04:48.570: debug : remoteIO:9877 : We have the buck 39 0x9d964f0 0x9d964f0
17:04:49.022: debug : remoteIODecodeMessageLength:9233 : Got length,
now need 576 total (572 more)
17:04:49.022: debug : remoteIOEventLoop:9728 : Giving up the buck 39
0x9d964f0 (nil)
17:04:49.022: debug : remoteIO:9908 : All done with our call 39 (nil) 0x9d964f0
17:04:49.022: debug : virNetworkGetName:6288 : network=0x9d96488
error: Failed to start network net0
17:04:49.022: debug : virNetworkFree:6228 : network=0x9d96488
17:04:49.022: debug : virUnrefNetwork:601 : unref network 0x9d96488 net0 1
17:04:49.022: debug : virReleaseNetwork:557 : release network
0x9d96488 net0 bb909289-700a-87f8-c075-910209d1a2e3
17:04:49.022: debug : virReleaseNetwork:571 : unref connection 0x9d82658 2
error: internal error '/sbin/iptables --table filter --delete INPUT
--in-interface virbr0 --protocol udp --destination-port 69 --jump
ACCEPT' exited with non-zero status 1 and signal 0: iptables: Bad rule
(does a matching rule exist in that chain?).

--

Can someone help me on this?

-- 
Fernando


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]