[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [virt-tools-list] problem installing a fedora rootfs with febootstrap on ubuntu



On 06/04/2010 06:47 PM, Richard W.M. Jones wrote:
On Fri, Jun 04, 2010 at 06:21:01PM +0200, Daniel Lezcano wrote:
On 06/04/2010 05:57 PM, Richard W.M. Jones wrote:
On Fri, Jun 04, 2010 at 05:53:52PM +0200, Daniel Lezcano wrote:

The download happens without problems but when the installation begins,
there are a lot of dependency problems like:

Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
libc.so.6()(64bit) is needed by pam-1.1.0-7.fc12.x86_64
libc.so.6(GLIBC_2.2.5)(64bit) is needed by pam-1.1.0-7.fc12.x86_64
libc.so.6(GLIBC_2.3)(64bit) is needed by pam-1.1.0-7.fc12.x86_64
libc.so.6(GLIBC_2.3.4)(64bit) is needed by pam-1.1.0-7.fc12.x86_64
libc.so.6(GLIBC_2.4)(64bit) is needed by pam-1.1.0-7.fc12.x86_64
libc.so.6(GLIBC_2.7)(64bit) is needed by pam-1.1.0-7.fc12.x86_64
libc.so.6(GLIBC_2.8)(64bit) is needed by pam-1.1.0-7.fc12.x86_64
libcrypt.so.1()(64bit) is needed by pam-1.1.0-7.fc12.x86_64
libcrypt.so.1(GLIBC_2.2.5)(64bit) is needed by pam-1.1.0-7.fc12.x86_64
libdb-4.7.so()(64bit) is needed by pam-1.1.0-7.fc12.x86_64
libdl.so.2()(64bit) is needed by pam-1.1.0-7.fc12.x86_64
libdl.so.2(GLIBC_2.2.5)(64bit) is needed by pam-1.1.0-7.fc12.x86_64
libnsl.so.1()(64bit) is needed by pam-1.1.0-7.fc12.x86_64
libnsl.so.1(GLIBC_2.2.5)(64bit) is needed by pam-1.1.0-7.fc12.x86_64
libutil.so.1()(64bit) is needed by pam-1.1.0-7.fc12.x86_64
libutil.so.1(GLIBC_2.2.5)(64bit) is needed by pam-1.1.0-7.fc12.x86_64
....

I tried with the version 2.1 and 2.7, I have for both the same problem.

Did I missed something ?

The errors seem to indicate that you are installing pam, but somehow
not installing glibc.  I would assume that glibc is a dependency of
pam, but maybe not.  What's the full command line and full output?

The command line is :

  "febootstrap fedora-12 ./f12"

I tried to get a fedora 10 and I got the same result (in attachment).
Fedora 10 seems unlikely to work because it's long out of support.

Also you'll need to check the version of rpm and yum [on Ubuntu]
matches the version that was around when Fedora 12 was released (or
later, but not earlier versions).

I tried on an ubuntu 10.04:

yum : 3.2.25-1ubuntu2
rpm : 4.7.2-1lbuild1

on fedora 12:

yum : 3.2.25
rpm : 4.7.1-6

At the first glance they seems ok, no ?
The versions look OK.

I guess the thing to do is to manually download the RPMs and try to
see if the dependencies resolve, eg:

$ rpm -q --requires -p http://www.mirrorservice.org/sites/download.fedora.redhat.com/pub/fedora/linux/releases/12/Everything/x86_64/os/Packages/pam-1.1.0-7.fc12.x86_64.rpm

versus:

$ rpm -q --provides -p http://www.mirrorservice.org/sites/download.fedora.redhat.com/pub/fedora/linux/releases/12/Everything/x86_64/os/Packages/glibc-2.11-2.x86_64.rpm

febootstrap is just a thin shell script wrapper around 'yum' and 'rpm'
so any dep resolving bug is likely to be a bug in yum/rpm.

Rich.

Thank you very much Richard, I will look forward and check against 'yum' and 'rpm'.

  -- Daniel


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]