[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[virt-tools-list] create VM windows with virt-install 0.500.2



		hello,

	I upgrade my virt-install tools to version 0.500.2 and now I get
an error message when I want to create VM for windows (no problem for
Debian Lenny VM) :

Traceback (most recent call last):
  File "/usr/bin/virt-install", line 972, in <module>
    main()
  File "/usr/bin/virt-install", line 782, in main
    continue_inst = guest.get_continue_inst()
  File "/usr/lib/pymodules/python2.5/virtinst/Guest.py", line 807, in
get_continue_inst
    if not self.get_config_xml(install=True):
  File "/usr/lib/pymodules/python2.5/virtinst/Guest.py", line 776, in
get_config_xml
    xml = add("%s" % self._get_device_xml(install))
  File "/usr/lib/pymodules/python2.5/virtinst/FullVirtGuest.py", line
94, in _get_device_xml
    return (emu_xml + Guest._get_device_xml(self, install))
  File "/usr/lib/pymodules/python2.5/virtinst/Guest.py", line 641, in
_get_device_xml
    xml = _util.xml_append(xml, dev.get_xml_config())
  File "/usr/lib/pymodules/python2.5/virtinst/VirtualDisk.py", line
1120, in get_xml_config
    raise ValueError(_("'disknode' or self.target must be set!"))
ValueError: 'disknode' or self.target must be set!

	I use this command to create the VM :

virt-install --connect qemu:///system -n dc -r 512 --vcpus=1 -c
/Iso/win2k3std_64bits.iso --vnc --noautoconsole --os-type windows
--os-variant win2k3 --accelerate --network=bridge:br1 --hvm -k fr --disk
path=/dev/vg-fr-kvm05/lv-dc

	This command works fine with 0.500.0.

	I use virt-install on Debian Lenny.

	David.

Attachment: signature.asc
Description: Digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]