[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[virt-tools-list] virt-install on rhel6 beta2 broken pxe boot



 RHEL 6 beta refresh distributes: python-virtinst-0.500.3-5.el6.noarch

Here is the command we are attempting:

virt-install --noreboot \
--hvm --virt-type=kvm \
--pxe \
--name=008949-akrteria.com \
--ram=1024 \
--vcpus=1 \
--arch=x86_64 \
--uuid=9d50ff43-746a-48a0-8d02-1ee8a6c3bcf8 \
--os-type=linux \
--os-variant=rhel5 \
--disk path=/dev/mapper/008949,bus=virtio,cache=none --network=bridge=br1,model=virtio,mac=52:54:ac:14:24:f4 \
--vnc --vnclisten=0.0.0.0 \
--noautoconsole --wait=-1


The result is that the VM starts, but immediately says: "Using legacy NIC wrapper on <MAC Address>"

If I change the network model to e1000 that message does not appear but the other symptoms are the same.

Running tshark against the host's br1 interface, as well as the dhcp server's interface, shows no packets from this VM at all. Not even the dhcp broadcast.

The pxe boot times out after a few seconds and fails.

This command worked flawlesly on rhel 5.5 with: python-virtinst-0.500.3-2, which we manually installed from the F13 source package.

So the main difference here might be the seabios code now being used on rhel6 beta refresh. We have attempted to find any bugs against seabios for pxe boot, but failed to find any.

Any help is very welcome!


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]