[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [virt-tools-list] PendingDeprecationWarning



On 04/07/2011 11:09 AM, george wrote:
>   # virt-manager --version
> 0.8.5
> 
> i try to start virt-manager and get warning message:
>   # virt-manager
> /usr/lib/python2.7/site-packages/dbus/types.py:6: 
> PendingDeprecationWarning: The CObject type is marked Pending 
> Deprecation in Python 2.7.  Please use capsule objects instead.
>    from _dbus_bindings import ObjectPath, ByteArray, Signature, Byte,\
> 
> Then virt-manager is started and similar works correctly..
> But that this error means?
> 

The dbus python bindings are using a deprecated python API and should
switch to the newer recommended method. It's just a warning to the
developer that the bindings should be updated. Since this is dbus code
it's not something specific to virt-manager and is harmless for the time
being.

If you want the error to go away, I'd recommend filing a bug with the
dbus guys.

- Cole


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]