[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[virt-tools-list] [libosinfo 1/2] Require and link against libiso9660



From: "Zeeshan Ali (Khattak)" <zeeshanak gnome org>

---
 configure.ac       |    5 +++++
 osinfo/Makefile.am |    1 +
 2 files changed, 6 insertions(+), 0 deletions(-)

diff --git a/configure.ac b/configure.ac
index bf5681b..c0ad238 100644
--- a/configure.ac
+++ b/configure.ac
@@ -18,6 +18,11 @@ m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
 PKG_CHECK_MODULES([GOBJECT], [gobject-2.0])
 PKG_CHECK_MODULES([GIO], [gio-2.0])
 PKG_CHECK_MODULES([LIBXML], [libxml-2.0 >= 2.6.0])
+AC_CHECK_HEADER([cdio/iso9660.h],
+                [AC_CHECK_LIB([iso9660],
+                              [iso9660_open],
+                              [ISO9660_LIBS="-liso9660"])])
+AC_SUBST([ISO9660_LIBS])
 
 GTK_DOC_CHECK([1.10],[--flavour no-tmpl])
 
diff --git a/osinfo/Makefile.am b/osinfo/Makefile.am
index 5982923..d28d655 100644
--- a/osinfo/Makefile.am
+++ b/osinfo/Makefile.am
@@ -35,6 +35,7 @@ libosinfo_1_0_la_LDFLAGS = \
 	$(LIBXML_LIBS) \
 	$(GOBJECT_LIBS) \
 	$(GIO_LIBS) \
+	$(ISO9660_LIBS) \
 	$(VERSION_SCRIPT_FLAGS)$(LIBOSINFO_VERSION_FILE) \
         -version-info $(LIBOSINFO_VERSION_INFO) \
 	$(NO_UNDEFINED_FLAGS)
-- 
1.7.6


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]