[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[virt-tools-list] [Request] Error Message Improvement

Hey folks, newbie here.


I’ve spent the last few days getting a setup running, mainly because I wanted to test the “migrate” feature.  Well, let me take a step back and give the setup first!


Server 1 – Fedora 15, NFS & virt-manager – acting as the NFS server for storage & vm-manager (powering on and off VMs, migrating, etc)

Server 2 – Fedora 15, virt-manager, etc – Acting as a VM host

Server 3 – Fedora 15, virt-manager, etc – Acting as a VM host


I dealt with a number of error messages and quirks along the way, many of which I had written down.  The few that I have I may write up into the wiki, but the main thing I’d like to see is some work on error messages.


For example, if openssh-askpass isn’t installed (and the user is trying to manage another system via SSH and does not have public key authentication setup), the error message is “check that libvirtd is running”, not that a package is missing. This also occurs when the system is offline. I think this was noted in a bug report when I googled it.


But my biggest quirk came with trying to migrate a machine.  The error always was relating to setting the owner/group, or setting security context.  I went as far as disabling selinux on all of the systems after running a setbool –p virt_use_nfs (I think) didn’t work & chmod 777 to all associated VM files.  No dice.


After compiling to the latest virt-manager, virtinstall, virt-viewer (and having to find all of the required packages ^^;;) it still threw the same error – unable to set security context and unable to set owner/group.

Yet when I tried the command “chown 107:107 /var/lib/libvirt/images/VM1-NFS/Fedora14.img” the path the error said on the host the VM was running on, it worked.

And finally I figured out the issue… it was trying to set it from the OTHER host… which had a slightly different storage-pool path.



/var/lib/libvirt/images/VM1-NFS (note the uppercase NFS).


Never once did a dialog in setup (new pool) or error say to check that the storage paths and names were the same on all hosts L. I could have had VM1-nfs on one host, and nfs-VM1 on another and the same issue would have occurred w/o much hint as to why.


So please, if possible in the next major release or two, can some focus be put towards relevant error messages?


I among many would appreciate it J and if there is anything I can do to assist (bug reports? Feature requests? Wiki articles?) I’d be glad to assist. 


Virt-manager rocks though guys!


-          Nick Kesick

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]