[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[virt-tools-list] Fwd: [libosinfo 1/2] Require and link against libiso9660



Bah, Forgot to hit reply-all..


---------- Forwarded message ----------
From: Zeeshan Ali (Khattak) <zeeshanak gnome org>
Date: Mon, Aug 8, 2011 at 3:08 PM
Subject: Re: [virt-tools-list] [libosinfo 1/2] Require and link
against libiso9660
To: "Daniel P. Berrange" <berrange redhat com>


Hi Daniel,

On Mon, Aug 8, 2011 at 11:23 AM, Daniel P. Berrange <berrange redhat com> wrote:
> libosinfo is licensed  LGPLv2+, so we cannot link to libiso9660.so
> I'm afraid.

 Darn! I was so excited about this library that I forgot to check the
license. :(

> If there's no other possible LGPLv2+ compatible library that does
> this kind of thing, then the other option is to spawn /usr/bin/iso-info
> and parse the output.
>
> Or create a /usr/libexec/libosinfo-isohelper helper binary that does
> link against libiso9660.so and returns the information in a format that
> is more easily consumable by libosinfo than that from iso-info binary.

 I'll first look into using iso-info directly since it seems to
produce output thats already consumable by us.

--
Regards,

Zeeshan Ali (Khattak)
FSF member#5124



-- 
Regards,

Zeeshan Ali (Khattak)
FSF member#5124


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]