[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [virt-tools-list] Guest doesn't reboot after installation with virt-install



On Fri, Aug 12, 2011 at 04:05:05PM -0500, Brad Ison wrote:
> Hello,
> 
> I'm installing Ubuntu 10.04 on a KVM host with the following:
> 
> virt-install \
>     --connect qemu:///system \
>     -n "${NAME}" \
>     --vcpus=4 -r 4096 \
>     --disk "path=/dev/vmdisk/${NAME}" \
>     --vnc --vnclisten 0.0.0.0 --noautoconsole \
>     --os-type linux --os-variant ubuntulucid \
>     --network bridge=br0 \
>     --location=/path/to/installer-amd64/ \
>     --extra-args="netcfg/get_ipaddress=${IP}
> netcfg/get_netmask=255.255.255.0 netcfg/get_gateway=${GW}
> netcfg/confirm_static=true netcfg/get_hostname=${NAME}"
> 
> 
> The installer reboots after finishing the installation, but the guest
> just powers off instead. After powering the guest on, reboots work
> normally.
> 
> Is that expected? Is there a way to allow the guest to reboot into the
> newly installed system automatically after installation?

No, it's not expected.  For me, virt-install reboots the guest once,
then virt-install exits.  You can control this with the --noreboot
option, although I've never needed to.

(There is also a --boot option but it seems unrelated to your problem)

Rich.

-- 
Richard Jones, Virtualization Group, Red Hat http://people.redhat.com/~rjones
virt-top is 'top' for virtual machines.  Tiny program with many
powerful monitoring features, net stats, disk stats, logging, etc.
http://et.redhat.com/~rjones/virt-top


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]