[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [virt-tools-list] vm fails to boot, need to modify guest registry



Nope, I tried changing disk(0) to disk(1), then both rdisk and disk to 1, then just rdisk by itself. It's the damnedest thing, I've never seen this before.

It happened to two servers, one running RHEL 6 as a host, and the other Scientific Linux 6 as the host. Both on the same day.

On 08/22/2011 12:55 PM, Kenny Armstrong wrote:
I'll give that a shot. Someone else suggested changing the disk order in the xml file, but when I run guestfish on each disk, the order is already correct in the xml file.

I'll dig into the boot.ini idea.

-Kenny

On 08/22/2011 11:57 AM, Richard W.M. Jones wrote:
On Mon, Aug 22, 2011 at 11:03:03AM -0400, Kenny Armstrong wrote:
Nevermind, just realized the error in the question.  Windows needs
to boot in order to read anything from the registry, however we
can't even get that far.
Did W2K3 use BCD or BOOT.INI?  If it was old enough to use BOOT.INI
then you might try editing it:

# guestfish -i -d WinXPRecConsole
<fs>  edit /boot.ini
and I think change all disk(0) -> disk(1) (or maybe rdisk(0) -> rdisk(1)?)

Rich.


_______________________________________________
virt-tools-list mailing list
virt-tools-list redhat com
https://www.redhat.com/mailman/listinfo/virt-tools-list


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]