[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [virt-tools-list] C'ant migrate with virt-manager or virsh



Hi,

I configured hostname and domainname for both systems, and added both to eachother's /etc/hosts. Hostname and /etc/hosts of systems should look like this?

[root cluster ~]# hostname
cluster.pisolar
[root cluster ~]# cat /etc/hosts
127.0.0.1    cluster    localhost.localdomain    localhost    localhost4
::1    cluster    localhost6.localdomain6    localhost6
192.168.0.67 fedorao.pisolar fedorao

AND


[root fedorao ~]# hostname
fedorao.pisolar
[root fedorao ~]# cat /etc/hosts
127.0.0.1    localhost.localdomain    localhost    localhost4
::1    localhost6.localdomain6    localhost6
192.168.1.4 cluster.pisolar cluster


(cluster has ip 192.168.1.4 and fedorao has ip 192.168.0.67)

I also created a directory /media/nfs067 in machine fedorao.pisolar, shared it with cluster.pisolar using nfs, and mounted it in /media/nfs067, in case different paths be a problem to virsh and virt-manager. =D

Then I created a VM with disk in /media/067 and tried to live migrate it with virt-manager 0.8.6. Got this error message:

Unable to migrate guest: operation failed: Migration unexpectedly failed
Unable to migrate guest: operation failed: Migration unexpectedly failed
Traceback (most recent call last):
  File "/usr/local/share/virt-manager/virtManager/asyncjob.py", line 45, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/local/share/virt-manager/virtManager/migrate.py", line 523, in _async_migrate
    vm.migrate(dstconn, migrate_uri, rate, live, secure, meter=meter)
  File "/usr/local/share/virt-manager/virtManager/domain.py", line 1141, in migrate
    self._backend.migrate(destconn.vmm, flags, newname, interface, rate)
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 518, in migrate
    if ret is None:raise libvirtError('virDomainMigrate() failed', dom=self)
libvirtError: operation failed: Migration unexpectedly failed

Using virsh, I get the same error:

[root fedorao ~]# virsh migrate --live lol qemu+ssh://192.168.1.4/system
root 192 168 1 4's password:
erro:operation failed: Migration unexpectedly failed

I'm feeling a bit lost right now. =/


On Wed, Feb 2, 2011 at 10:14 AM, Daniel P. Berrange <berrange redhat com> wrote:
On Wed, Feb 02, 2011 at 09:25:47AM -0300, Bruno Lamps wrote:
> Updating the thread:
>
> I was using fedora 13 (kernel 2.6.32) in one machine and fedora 14 (kernel
> 2.6.35) in other, so I made a fresh install in the first machina, so now
> it's running fedora 14 with 2.6.35 x64 kernel, same as the second machine.
>
> Now when I try to migrate a VM through virt-manager, the following message
> appears:
>
> Erro ao receber a validação de entrada: [Errno -2] Nome ou serviço
> > desconhecido
> > Traceback (most recent call last):
> >   File "/usr/local/share/virt-manager/virtManager/migrate.py", line 423, in
> > finish
> >     dsthost = destconn.get_qualified_hostname()
> >   File "/usr/local/share/virt-manager/virtManager/connection.py", line 342,
> > in get_qualified_hostname
> >     return gethostbyaddr(gethostname())[0]
> > gaierror: [Errno -2] Nome ou serviço desconhecido
> >
>
> In english, this error means something like "error receiving validation for
> input: Error n 2 Unknown name or service. Traceback blablabla...

This suggests something is mis-configured in either DNS, or /etc/hosts
or the OS hostname or a mix

You need the configured 'hostname' to correctly resolve either via DNS
or an /etc/hosts entry or both, and for it to point to a public IP of
the machine, not 127.0.0.1

Daniel
--
|: http://berrange.com      -o-    http://www.flickr.com/photos/dberrange/ :|
|: http://libvirt.org              -o-             http://virt-manager.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: http://entangle-photo.org       -o-       http://live.gnome.org/gtk-vnc :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]