[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [virt-tools-list] 'gtk.CheckMenuItem' error

On 02/14/2011 09:50 PM, greg s wrote:
> I created a src directory on my CentOS desktop and ran the following:
> o    hg clone http://hg.fedorahosted.org/hg/virt-manager
> o    hg clone http://hg.fedorahosted.org/hg/python-virtinst
> o    hg clone http://hg.fedorahosted.org/hg/virt-viewer
> In the python-virtinst I ran python setup.py install.
> In the virt-viewer directory I needed to create an m4 directory, and comment
> out gdk_window_beep in display_vnc.c to build.  I then ran ./autogen.sh,
> ./configure, and make.
> In the virt-manager directory I ran ./autogen.sh, ./configure, and make.  Then
> when I try to run virt-manager in the local directory with python
> src/virt-manager.py a pop up error with the following information appears:
> Error starting Virtual Machine Manager: 'gtk.CheckMenuItem' object has no
> attribute 'get_label'
> Traceback (most recent call last):
>   File "src/virt-manager.py", line 456, in ?
>     main()
>   File "src/virt-manager.py", line 443, in main
>     options.no_conn_auto)
>   File "src/virt-manager.py", line 257, in show_engine
>     engine.show_manager()
>   File "/root/Desktop/src/virt-manager/src/virtManager/engine.py", line 749,
> in show_manager
>     self._do_show_manager(None)
>   File "/root/Desktop/src/virt-manager/src/virtManager/engine.py", line 688,
> in _do_show_manager
>     self.get_manager().show()
>   File "/root/Desktop/src/virt-manager/src/virtManager/engine.py", line 654,
> in get_manager
>     obj = vmmManager(self)
>   File "/root/Desktop/src/virt-manager/src/virtManager/manager.py", line 190,
> in __init__
>     self.enable_polling(None, None, init_val, typ)
>   File "/root/Desktop/src/virt-manager/src/virtManager/manager.py", line 1065,
> in enable_polling
>     current_text = widget.get_label().strip(disabled_text)
> AttributeError: 'gtk.CheckMenuItem' object has no attribute 'get_label'
> Anyone know what I need to do to fix the error?

We were using a GTK api that was not provided on RHEL5. I've pushed a fix
upstream now. You can apply the patch to your local tree and reinstall.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]