[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [virt-tools-list] virt-manager qemu error when changing Disk from IDE to Virtio Bus type...





On Wed, Nov 9, 2011 at 2:34 PM, Deepak Shetty <dpkshetty gmail com> wrote:
>
> Hi,
>    I have a running VM under virt-manager that uses IDE hd to boot from a .img file.
> After shutting it down, i change (under VM details) the IDE disk to VirtIO disk and it fails to start the VM and gives below error...
>
> Error starting domain: internal error process exited while connecting to monitor: char device redirected to /dev/pts/2
> qemu-kvm: -device rtl8139,netdev=hostnet0,id=net0,mac=52:54:00:1a:d4:19,bus=pci.0,addr=0x3: PCI: slot 3 function 0 not available for rtl8139, in use by virtio-blk-pci
> qemu-kvm: -device rtl8139,netdev=hostnet0,id=net0,mac=52:54:00:1a:d4:19,bus=pci.0,addr=0x3: Device 'rtl8139' could not be initialized
>
> Details:
>
> Error starting domain: internal error process exited while connecting to monitor: char device redirected to /dev/pts/2
> qemu-kvm: -device rtl8139,netdev=hostnet0,id=net0,mac=52:54:00:1a:d4:19,bus=pci.0,addr=0x3: PCI: slot 3 function 0 not available for rtl8139, in use by virtio-blk-pci
> qemu-kvm: -device rtl8139,netdev=hostnet0,id=net0,mac=52:54:00:1a:d4:19,bus=pci.0,addr=0x3: Device 'rtl8139' could not be initialized
>
>
> Traceback (most recent call last):
>   File "/usr/share/virt-manager/virtManager/asyncjob.py", line 45, in cb_wrapper
>     callback(asyncjob, *args, **kwargs)
>   File "/usr/share/virt-manager/virtManager/engine.py", line 956, in asyncfunc
>     vm.startup()
>   File "/usr/share/virt-manager/virtManager/domain.py", line 1048, in startup
>     self._backend.create()
>   File "/usr/lib/python2.7/dist-packages/libvirt.py", line 330, in create
>     if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
> libvirtError: internal error process exited while connecting to monitor: char device redirected to /dev/pts/2
> qemu-kvm: -device rtl8139,netdev=hostnet0,id=net0,mac=52:54:00:1a:d4:19,bus=pci.0,addr=0x3: PCI: slot 3 function 0 not available for rtl8139, in use by virtio-blk-pci
> qemu-kvm: -device rtl8139,netdev=hostnet0,id=net0,mac=52:54:00:1a:d4:19,bus=pci.0,addr=0x3: Device 'rtl8139' could not be initialized
>
>
> If i remove the IDE disk (using remove option from the VM details page) and add New hardware and select VirtIO disk under storage, it works, all other params remaning same for the storage.
>
> I believe it should also work when i just edit/change the original IDE disk to VirtIO, as the ability to change the Bus Type is enabled ??
>
>
This issue is already fixed in upstream.

 links : https://bugzilla.redhat.com/show_bug.cgi?id=710806
https://www.redhat.com/archives/virt-tools-list/2011-May/msg00057.html

> _______________________________________________
> virt-tools-list mailing list
> virt-tools-list redhat com
> https://www.redhat.com/mailman/listinfo/virt-tools-list


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]