[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[virt-tools-list] virt-install not rebooting guest after install



When installing RHEL guests via PXE/kickstart with virt-install the OS installs but then the guest is powered off.

Expected behaviour is for guest to reboot itself to finish the install.

Environment:
Red Hat Enterprise Linux Server release 6.1 (Santiago)
Linux ucm-buildhost 2.6.32-131.0.15.el6.x86_64 #1 SMP Tue May 10 15:42:40 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux

Packages:
libvirt-python-0.8.7-18.el6.x86_64
libvirt-client-0.8.7-18.el6.x86_64
libvirt-devel-0.8.7-18.el6.x86_64
libvirt-0.8.7-18.el6.x86_64

command line:
virt-install --name=rhel-56-i686 --arch=i686 --vcpus=1 --ram=1024 --os-type=linux --os-variant=rhel5.4 --disk /local/mnt/workspace/images/rhel-56-i686.qcow2,format=qcow2,cache=writeback --network=bridge:br0,mac=52:54:00:00:00:b7 --vnc --pxe --noautoconsole

No change when using the --noapic and --noacpi options.

Identical PXE/kickstart configuration reboots after install on physical hardware an VMware guests.

The correct kickstart line "reboot" is present.

Removing --noautoconsole has no effect.

Have not tried RHEL 6.2 beta.

I have a case open with Red Hat on this as well but wanted to query the virt-tools list as well if anyone else has seen this issue, has a workaround, of it this should be filed as a bug.

--
Micheal Waltz
Unix Configuration Management
Qualcomm Inc.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]