[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [virt-tools-list] installing from iso image problem



> Hmm, okay, so when you start virt-manager, MobileOtp3 isn't listed? Is that
> also the name you were using for a new VM that threw the 'name already in use'
> error?
>
> What's the output of virt-manager --debug when reproducing the reported issue?

Now MobileOtp3 was listed. I tried to run the VM and then got

Error starting domain: 'NoneType' object has no attribute 'info'

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 45, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/engine.py", line 959, in asyncfunc
    vm.startup()
  File "/usr/share/virt-manager/virtManager/domain.py", line 1129, in startup
    self._update_status()
  File "/usr/share/virt-manager/virtManager/domain.py", line 1355, in
_update_status
    info = self.get_info()
  File "/usr/share/virt-manager/virtManager/domain.py", line 1024, in get_info
    return self._backend.info()
AttributeError: 'NoneType' object has no attribute 'info'

virt-manager said

$ virt-manager --debug
2012-02-07 16:21:15,246 (virt-manager:175): Application startup
2012-02-07 16:21:15,273 (virt-manager:363): Launched as:
/usr/share/virt-manager/virt-manager.py --debug
2012-02-07 16:21:15,274 (virt-manager:364): GTK version: (2, 24, 7)
2012-02-07 16:21:18,325 (engine:338): About to connect to uris ['xen:///']
2012-02-07 16:21:18,380 (virt-manager:436): Connected to already
running instance.

and now MobileOtp3 has disappeared from the VM list in virt-manager.

- Gergely


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]