[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [virt-tools-list] [libosinfo] Put symbols into their corresponding versions in syms file



On Tue, Feb 7, 2012 at 4:04 PM, Daniel P. Berrange <berrange redhat com> wrote:
> On Tue, Jan 24, 2012 at 04:37:25PM +0100, Christophe Fergeau wrote:
>> Hey,
>>
>> I checked that these functions were added in these releases and that you
>> didn't forget some, however I think this will break the ABI for apps that
>> were compiled against 0.0.5 and are already using these symbols, so I'd
>> like to get Daniel's feedback on this.
>
> Yes this would break ABI compatibility. Since we haven't declared
> we are ABI stable though, I think it is acceptable at this time.

OK! I pushed this patch now.

> Given that we are at the Fedora 17 feature development target
> point, we should probably aim to be ABI stable from this forthcoming
> release onwards.   Likewise with libvirt-glib.

Agreed! Also gnome 3.3/4 code freeze is happening soon so it'll be
nice for that as well. We should start following the proper API
deprecation process after next releases of both as well.

-- 
Regards,

Zeeshan Ali (Khattak)
FSF member#5124


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]