[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[virt-tools-list] problems creating VMs from remote



Dear list,

I try to manage my kvm environment from one virtual server with
virt-manager. Virt-manager accesses the kvm-hypervisors with ssh.

I discovered one problem creating new virtual servers:

-------
A hypervisor is not running.  For kvm, load the kvm kernel modules.
If you want to run xen, reboot and load the xen kernel.


Traceback (most recent call last):
File "/usr/share/virt-manager/virtManager/engine.py", line 661, in show_create
    create = vmmCreate(virtman=True,key=0)
File "/usr/lib64/python2.6/site-packages/vminstall/gtk/interface.py", line 120, in __init__
    raise HypervisorError(HypervisorError.E_NO_HYPERVISOR)
HypervisorError: A hypervisor is not running. For kvm, load the kvm kernel modules. If you want to run xen, reboot and load the xen kernel.
-------

The error message is correct, as the management-server is a virtual server
and there is no hypervisor running. But as i wanted to create the vm
on the remote server. The vminstall script should check the remote server
and not the local server virt-manager is running on.

Is this a known bug? Is ist fied in recent versions?

I am using SLES 11 which uses old versions, libvirt-python 0.7.6-1.27.5,
virt-manager 0.8.4-1.7.11, virt-utils 1.1.3-1.3.3, libvirt 0.7.6-1.27.5,
virt-viewer 0.2.0-1.5.65, vm-install 0.4.32-0.3.6




Regards

   Michael Menge




--------------------------------------------------------------------------------

M.Menge                                Tel.: (49) 7071/29-70316
Universität Tübingen                   Fax.: (49) 7071/29-5912
Zentrum für Datenverarbeitung mail: michael menge zdv uni-tuebingen de
Wächterstraße 76
72074 Tübingen


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]