[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [virt-tools-list] Windows 7 don't boot in KVM on Fedora 16



On 03/02/2012 09:18 AM, Martin Edlman wrote:
> Hello,
> 
> after some time I tried again if there is any good change in KVM booting
> Windows 7. Still no luck.
> 
> I did fresh install of Windows 7 (32 bit) into KVM virtual machine
> (qemu-kvm, i686 arch) on my Fedora 16 (x64) running on HP Pavilion dv7 (4GB
> RAM, intel i7 CPU).
> 
> Installation went (slow but) fine. After that Windows refuse to boot and
> all I see is a cursor on top left corner. See attached log. First two boots
> are from installation, the last one is when Windows should boot to normal
> operation. According to the log, W7 was installed under qemu-kvm, i686
> arch, so it should be able to run.
> 
> I tried installing Windows XP and Fedora 16 (both 32bit versions, qemu-kvm,
> i686 arch). They both work fine.
> 
> I searched other sites and found that there are other users experiencing
> the same problem. See
> http://www.linuxquestions.org/questions/slackware-14/qemu-says-my-cpu-is-too-old-897074/.
> 
> I'm able to run W7 in VMWare Player with hw virtualization without problem
> and as others wrote (see link above) it's running fine in Virtual Box as well.
> 
> So I'm affraid there's a problem in qemu-kvm. Please try to fix it.
> 
> I (and i hope many other) would really appreciate it. I'd like to get rid
> of VMWare as it recompiles modules after each kernel update and when there
> are siginificant changes in kernel headers it won't compile (and run) at all.
> 
> Martin E.
> 

Is your host 32 or 64 bit?

Can you try recreating the guest, but this time at the end of the virt-manager
wizard, choose 'customize before install', 'processor', 'configuration', 'copy
cpu from host', 'apply', then start the install.

- Cole


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]