[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[virt-tools-list] under virt-manager, can't create a new VM instance from ISO image



dear community,

i can't use virt-manager to create a new VM instance. below is the steps i went through and the problems i got:

1) run virt-manager to create a new VM with name test
2) select "local install media (iso image ......)"
3) browse to import ubuntu iso from local harddisk
......
4)
a) if under "Advanced options", select "Virtual network 'default' : NAT(inactive)", then click Finish, got "Virtual Network is not active. Virtual Network 'default' is not active. Would you like to start the network now?", clidk Yes, got "Could not start virtual network 'default': internal error Network is already in use by interface br0"
b) if under "Advanced options", select "specify shared device name" and set "bridge name:" br0, then click Finish, got "Unable to complete install: 'internal error Process exited while reading console log output: char device redirected to /dev/pts/3
kvm: -drive file=/home/var/libvirt/images/test.img,if=none,id=drive-ide0-0-0,format=raw: could not open disk image /home/var/libvirt/images/test.img: Permission denied"

5) cancel the current new VM creation, then go to the /var/lib/images/, run "chmod 644 test.img", and then run "chown oneadmin test.img", then start to create a new VM again through "import existing disk image" option

6)
a) if under "Advanced options", select "Virtual network 'default' : NAT(inactive)", then click Finish, got "Virtual Network is not active. Virtual Network 'default' is not active. Would you like to start the network now?", clidk Yes, got "Could not start virtual network 'default': internal error Network is already in use by interface br0"
b) if under "Advanced options", select "specify shared device name" and set "bridge name:" br0, then click Finish, can start to boot into the VM instance, but got "No bootable device" error.

in virt-manager, all the other steps when creating a new VM instance are default.

as the errors shown in above, why it can't create a new VM instance from ISO image? why it can't create a new VM instance from the RAW image in local harddisk either? have anyone happened to these problem when creating new VM instance with virt-manager?

it is much appreciated if anyone can help with this?

thanks,
david su

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]