[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [virt-tools-list] [PATCH] Fix udev rule



On Thu, Oct 11, 2012 at 5:58 PM, Zeeshan Ali (Khattak)
<zeeshanak gnome org> wrote:
> On Thu, Oct 11, 2012 at 5:13 PM, David Zeuthen <davidz redhat com> wrote:
>>
>>
>>> > And can you confirm that David's updated rule fixes this issue?
>>
>> As I said in my other mail, there are many many reasons why things
>> can fail that are unrelated to the udev rule. Just proclaiming "it
>> doesn't work!" without investigating further and then scrapping a
>> good udev rule is non-sense.
>
> I didn't scrap anything. I'm saying more like I am unable to do any
> testing or comparison if things are broken for me with and without
> your change. I'm telling it here so that you or anyone else could help
> me figure out what is going on.
>
>> For example, there are some issues with the kernel loop driver and
>> partitioned devices, that's probably what Zeeshan is running into
>> (support for partitioned loop devices is rather new). I don't know
>> what kernel it's fixed in (if fixed at all). But it's easy to check
>> if the expected block devices show up. Maybe Zeeshan didn't do that,
>> I don't know.
>
> What I mean by "doesn't work" is that the media in question gets
> automatically mounted and I get the dialog "Open with Files". Somehow
> the udev rule never get triggered AFAICT:
>
>  $ osinfo-detect -f env /dev/sdb1
> OSINFO_BOOTABLE=1
> OSINFO_INSTALLER=http://fedoraproject.org/fedora/18
> OSINFO_LIVE=http://fedoraproject.org/fedora/18
> OSINFO_MEDIA=http://fedoraproject.org/fedora/18:3
> $ udevadm info --query=all /dev/sdb1|grep OSI
> $
>
> $ osinfo-detect -f env /dev/loop5p1
> OSINFO_BOOTABLE=1
> OSINFO_INSTALLER=http://fedoraproject.org/fedora/17
> OSINFO_MEDIA=http://fedoraproject.org/fedora/17:1
> $ udevadm info --query=all /dev/loop5p1|grep OSI
>
>> FWIW, the updated udev rule consistently works on my box; latest F18
>> packages, stock no customizations. That is, if the block devices
>> do show up.
>
> Great! If you have also tested against USB stick and hw CDROM, thats
> all the testing we need.

I tested with hw CDROM and it worked like a charm and David tested
with USB stick and loopback devices.

> In any case, I have no objection on pushing this change already as I
> haven't seen it to cause any regressions.

I have pushed this. Now I'll try to roll out a release..

Thanks David for the patch and Christophe for sending the patch here
and testing.

-- 
Regards,

Zeeshan Ali (Khattak)
FSF member#5124


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]