[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [virt-tools-list] virt-install: zero allocation on lvm volumes



Hi Cole,
On Tue, Oct 16, 2012 at 08:45:03PM -0400, Cole Robinson wrote:
> On 10/02/2012 04:30 PM, Doug Goldstein wrote:
> > On Tue, Oct 2, 2012 at 12:16 PM, Guido Günther <agx sigxcpu org> wrote:
> >> Hi,
> >> creating a vm with a virtual disk in an lvm pool e.g. via:
> >>
> >> virt-install --disk=pool=vm_test,size=3.0 ...
> >>
> >> results in (from libvirtd's log):
> >>
> >> virCommandWait:2332 : internal error Child process (/sbin/lvcreate --name test01.img -L 0K --virtualsize 3145728K vg_vm_test) unexpected exit status 5:   Unable to create new logical volume with no extents
> >>
> >> However using
> >>
> >> virt-install --disk=pool=vm_test,size=3.0,sparce=false ...
> >>
> >> works. I wonder what's the correct place to make sure we don't try to
> >> create LVM volumes with a zero allocation by default?
> >> Cheers,
> >>  -- Guido
> > 
> > I actually very recently brought this up on libvirt's IRC channel. The
> > question is do we want to disallow sparse allocations on LVM entirely?
> > Or just some small percentage be allocated and then grow to the
> > correct size. I feel the correct place to fix this is within libvirt
> > itself.
> > 
> 
> Fedora 18 had a bug filed about this:
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=866481
> 
> I just sent a libvirt patch that turns lvm allocation=0 into allocation=1 at
> lvcreate time:
> 
> https://www.redhat.com/archives/libvir-list/2012-October/msg00857.html

I checked that allocations of 1 work before sending the above report so
this is a welcome solution. Thanks!
 -- Guido


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]