[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [virt-tools-list] Error when cloning using virt-manager



Hi Eric,

Thanks for the feedback.

I don't quite understand why I need a storage pool on the client if I'm
cloning from and to the remote server, but here is the output.

This is what I get on all 3 machines: the host (Ubuntu) and 2 clients
(Debian and Gentoo)

On the host I have more than one virtual machine running with KVM. I use
virt-manager from the clients and connect via ssh as root.

If I login there as root and issue the commands you pointed out I get:
# virsh pool-list
Name                 State      Autostart
-----------------------------------------
default              active     yes

# virsh pool-info default
Name:           default
UUID:           9ffa74fe-6efa-9b5e-5090-33a86cf25073
State:          running
Capacity:       535.35 GB
Allocation:     57.41 GB
Available:      477.94 GB

Then on the Debian machine which has no virtual machine running, if I
run the above commands as the user I use with virt-manager I get:

# virsh pool-list
Name                 State      Autostart
-----------------------------------------

# virsh pool-info default
error: failed to get pool 'default'
error: Storage pool not found: no pool with matching name 'default'

This is the machine where using virt-manager to connect to the server
and cloning raises no errors.

On the Gentoo machine, the output is the same the Debian machine, but
doing the same operation on virt-manager fails with the error from before.

I thought that you don't need to have libvirtd running on the clients if
you only want to manage remote hosts, but in case I read it wrong I
tried your suggestion of creating a default pool on the clients. With my
normal user I still can get output with virsh pool-list and pool-info. I
do if I run it as root.

So I restarted all applications related with virtualization but it
didn't make a difference.

I also tried to run virt-manager as root to workaround the permission
issue but the clone error still shows up.

So I'm back at square one... Any further ideas on what could be wrong?

Thanks again,
Renato


Quoting Eric Blake on 06-09-2012 20:50:
> On 09/06/2012 09:04 AM, Renato Alves wrote:
>>
>> However, from a Gentoo machine running virt-manager 0.9.4 (also tried
>> 0.8.7) I can't clone a machine and I always get the error:
>>
> 
>> ValueError: Could not use path
>> '/var/lib/libvirt/images/base-debian-clone.img' for cloning: invalid
>> storage volume pointer in no storage vol with matching path
> 
> This sounds like you don't have a storage pool running on the directory
> /var/lib/libvirt/images (Fedora pre-installs a 'default' storage pool at
> this location, but I suspect that your gentoo machine did not).  To
> confirm, compare the output of these commands between your two boxes:
> 
> virsh pool-list
> virsh pool-info default
> 
>>
>> The error seems to point to a missing image, however I've checked and
>> the image exists on that folder on the remote server.
> 
> Not a missing image, so much as a missing storage pool.  Libvirt can
> only clone files that live in a storage pool, and we haven't yet wired
> it up to be smart enough to auto-instantiate a transient pool around the
> directory of all files that are not already in a persistent pool
> (although I someday want to get to that point).
> 
>> This error doesn't happen on the Debian machine. There I can clone
>> without any problem.
> 
> Again, probably a case of your distro automatically installing a
> 'default' pool.
> 

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]