[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [virt-tools-list] [virt-viewer 5/7] mingw: Build a gtk2 version of virt-viewer



ack

----- Mensaje original -----
> The nsis file we ship is generating an installer for a GTK+2 build
> of virt-viewer, so it's inconsistent for the mingw-virt-viewer
> spec file to generate a GTK+3 build. Switch to building a GTK+2
> version of virt-viewer in mingw-virt-viewer.spec
> ---
>  mingw-virt-viewer.spec.in | 10 +++++-----
>  1 file changed, 5 insertions(+), 5 deletions(-)
> 
> diff --git a/mingw-virt-viewer.spec.in b/mingw-virt-viewer.spec.in
> index 9f69c5b..cf657f7 100644
> --- a/mingw-virt-viewer.spec.in
> +++ b/mingw-virt-viewer.spec.in
> @@ -14,14 +14,14 @@ BuildRequires:  mingw32-filesystem >= 23
>  BuildRequires:  mingw64-filesystem >= 23
>  BuildRequires:  mingw32-glib2 >= 2.22
>  BuildRequires:  mingw64-glib2 >= 2.22
> -BuildRequires:  mingw32-gtk3 >= 3.0.0
> -BuildRequires:  mingw64-gtk3 >= 3.0.0
> +BuildRequires:  mingw32-gtk2
> +BuildRequires:  mingw64-gtk2
>  BuildRequires:  mingw32-libvirt >= 0.9.7
>  BuildRequires:  mingw64-libvirt >= 0.9.7
>  BuildRequires:  mingw32-libxml2
>  BuildRequires:  mingw64-libxml2
> -BuildRequires:  mingw32-gtk-vnc2 >= 0.4.3
> -BuildRequires:  mingw64-gtk-vnc2 >= 0.4.3
> +BuildRequires:  mingw32-gtk-vnc >= 0.4.3
> +BuildRequires:  mingw64-gtk-vnc >= 0.4.3
>  BuildRequires:  pkgconfig
>  
>  BuildArch:      noarch
> @@ -50,7 +50,7 @@ MinGW Windows virt-viewer console application
>  
>  
>  %build
> -%mingw_configure --with-gtk=3.0
> +%mingw_configure --with-gtk=2.0
>  %mingw_make %{?_smp_mflags} V=1
>  
>  
> --
> 1.8.1
> 
> _______________________________________________
> virt-tools-list mailing list
> virt-tools-list redhat com
> https://www.redhat.com/mailman/listinfo/virt-tools-list
> 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]