[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[virt-tools-list] [virt-viewer] Fix warning when compiling without spice-gtk support



When remote-viewer is compiled without spice-gtk support, spice-session.h
will not get included in remote-viewer.c, causing these warnings:

remote-viewer.c: In function 'remote_viewer_start':
remote-viewer.c:693:9: warning: implicit declaration of function
'virt_viewer_session_set_file' [-Wimplicit-function-declaration]
remote-viewer.c:693:9: warning: nested extern declaration of
'virt_viewer_session_set_file' [-Wnested-externs]
---
 src/remote-viewer.c | 1 +
 1 file changed, 1 insertion(+)

diff --git a/src/remote-viewer.c b/src/remote-viewer.c
index b296d67..0cf9f1f 100644
--- a/src/remote-viewer.c
+++ b/src/remote-viewer.c
@@ -36,6 +36,7 @@
 #endif
 #include "virt-viewer-app.h"
 #include "virt-viewer-file.h"
+#include "virt-viewer-session.h"
 #include "remote-viewer.h"
 
 #ifndef G_VALUE_INIT /* see bug https://bugzilla.gnome.org/show_bug.cgi?id=654793 */
-- 
1.8.1


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]