[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [virt-tools-list] Problem running virt-manager 0.10.0



Hi,

Thanks so much for your response. Here's the output:

# virt-manager --debug
2013-07-10 14:57:15,641 (cliutils:75): virt-manager startup
2013-07-10 14:57:15,641 (virt-manager:199): Launched as:
['/usr/share/virt-manager/virt-manager', '--debug']
2013-07-10 14:57:15,641 (virt-manager:200): virt-manager version: 0.10.0
2013-07-10 14:57:15,642 (virt-manager:201): virtManager import: <module
'virtManager' from '/usr/share/virt-manager/virtManager/__init__.pyc'>
2013-07-10 14:57:15,753 (virt-manager:247): GTK version: 3.6.4

(virt-manager:20872): GLib-GIO-ERROR **: Settings schema
'org.virt-manager.virt-manager' is not installed

Trace/breakpoint trap



Regards

Erik

On 07/10/2013 02:49 PM, � wrote:
> Hi Erick,
> 
> Could you try to run:
> 
> virt-manager --debug
> 
> And show the output?
> 
> Best regards,
> 
> Leonardo Garcia
> 
> On 07/10/2013 04:32 PM, Erik Lotspeich wrote:
>> Hi,
>>
>> I decided to move to virt-manager 0.10.0. The problem is when I run it,
>> nothing happens (python crashes maybe?):
>>
>> # virt-manager
>> #
>>
>> To try to debug the problem a bit, I captured some output:
>>
>> #  python -d -v /usr/local/share/virt-manager/virt-manager
>>
>> [omitted some output for brevity]
>>
>> dlopen("/usr/lib64/python2.7/lib-dynload/cPickle.so", 2);
>> import cPickle # dynamically loaded from
>> /usr/lib64/python2.7/lib-dynload/cPickle.so
>> import libvirt # precompiled from
>> /usr/lib64/python2.7/site-packages/libvirt.pyc
>> dlopen("/usr/local/lib64/python2.7/site-packages/libvirtmod.so", 2);
>> import libvirtmod # dynamically loaded from
>> /usr/local/lib64/python2.7/site-packages/libvirtmod.so
>> # /usr/share/virt-manager/virtcli/cliconfig.pyc matches
>> /usr/share/virt-manager/virtcli/cliconfig.py
>> import virtcli.cliconfig # precompiled from
>> /usr/share/virt-manager/virtcli/cliconfig.pyc
>> # /usr/lib64/python2.7/ConfigParser.pyc matches
>> /usr/lib64/python2.7/ConfigParser.py
>> import ConfigParser # precompiled from
>> /usr/lib64/python2.7/ConfigParser.pyc
>> import virtManager # directory /usr/share/virt-manager/virtManager
>> # /usr/share/virt-manager/virtManager/__init__.pyc matches
>> /usr/share/virt-manager/virtManager/__init__.py
>> import virtManager # precompiled from
>> /usr/share/virt-manager/virtManager/__init__.pyc
>> #
>>
>> It looks like python just dies.
>>
>> I have libvirt 1.1.0, libvirt-glib 0.1.7, qemu-1.4.2, spice-gtk 0.20,
>> spice 0.12.3, spice-protocol 0.12.6, usbredir 0.6, and virt-viewer 0.5.6.
>>
>> I built spice-gtk and virt-viewer with GTK 3.0 support. Previously, I
>> had these compiled with GTK 2.0 support and my whole setup was working
>> great with virt-manager 0.9.5.
>>
>> Any help would be appreciated.
>>
>> Thanks!
>>
>> Regards
>>
>> Erik
>>
>> _______________________________________________
>> virt-tools-list mailing list
>> virt-tools-list redhat com
>> https://www.redhat.com/mailman/listinfo/virt-tools-list
>>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]