[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [virt-tools-list] [PATCH virt-viewer] msi: learn to build a non-privileged per-user installer



Hey,

I guess it's not possible to have a single installer handling both cases,
which does user install if it does not have enough privileges, admin
install if it does have enough privileges, and a command-line arg to force
user-install?

On Thu, Jul 11, 2013 at 09:30:18PM +0200, Marc-André Lureau wrote:
> @@ -22,13 +32,13 @@
>  
>    <?define UpgradeCode = "5B027138-1A63-49E6-877E-055E5EEC1903"?>
>    <Product Id="*"
> -           Name="VirtViewer $(var.Version) ($(var.ArchString))"
> +           Name="VirtViewer $(var.Version) ($(var.ArchString)$(var.UserString))"
>             Manufacturer="$(env.MANUFACTURER)"
>             Version="$(var.Version)"
>             UpgradeCode="$(var.UpgradeCode)"
>             Language="1033">
>  
> -    <Package InstallerVersion="200" Compressed="yes" Comments="comments"/>
> +    <Package InstallerVersion="200" Compressed="yes" InstallScope="$(var.Scope)"/>

'Comments' is removed here, is it intentional?

Looks good otherwise,

Christophe

Attachment: pgpLft1ChA0LN.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]