[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [virt-tools-list] issues with vmm-preferences.ui in glade3



On 06/05/2013 09:47 PM, Leonardo Augusto Guimarães Garcia wrote:
> Hi,
> 
> While trying to edit vmm-preferences.ui in glade3 that is currently
> available in Fedora 18 (glade3-3.8.3-1.fc18.x86_64) I hit the following
> error that crashed glade-3:
> 
> (glade-3:2379): GLib-GObject-ERROR **: cannot create instance of
> abstract (non-instantiatable) type `GtkBox'
> 

This being good or bad version doesn't excuse glade to crash, you could
file a bug for that.

> Is this a known issue or am I using the "wrong" version of glade3? It
> seems that the experience with glade varies a lot depending on the
> version being used...
> 

I'm not sure how gtk3 packages are and should be labeled in fedora, but
it looks like the 3.8.3 version is gtk2 (despite the fact that it is
called 'glade3' or 'glade-3') and normal version 3.14.2 in this package:

glade-3.14.2-2.fc18.x86_64

is gtk3.  You can use this to edit the GUI and it will work.  However I
have no idea why it is packaged this way.  I'll try to find out.

Have a nice day,
Martin


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]