[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[virt-tools-list] Upstream : virt-install and virt-manager fails to install the guest with the error "qemu: could not load PC BIOS 'bios.bin'"




Hi All,

Upstream : virt-install and virt-manager fails to install the guest with the error "qemu: could not load PC BIOS 'bios.bin'"

Kernel, Qemu, Libvirt, Virt-Manager is built from the source (git).

kernel version : 3.9.0+
qemu version : QEMU emulator version 1.5.0
libvirt version : 1.0.5
virt-install : 0.600.3

Guest installation fails for Standard PC machine type.

virt-install --name vm_name --cdrom <iso path> --disk <disk path > --ram 2000 --machine pc

Starting install...
ERROR    internal error process exited while connecting to monitor: char device redirected to /dev/pts/1
qemu: could not load PC BIOS 'bios.bin'

Domain installation does not appear to have been successful.
If it was, you can restart your domain by running:
  virsh --connect qemu:///system start win7
otherwise, please restart your installation.

Where as the qemu installation succeeds with the same machine type (standard pc)

qemu-system-x86_64 -cdrom <iso_path> -hda <disk_path> -boot d -m 1000 -machine pc

Below is the list of supported machine type:

qemu-system-x86_64 -M ?
Supported machines are:
none                 empty machine
pc                   Standard PC (i440FX + PIIX, 1996) (alias of pc-i440fx-1.5)
pc-i440fx-1.5        Standard PC (i440FX + PIIX, 1996) (default)
pc-i440fx-1.4        Standard PC (i440FX + PIIX, 1996)
pc-1.3               Standard PC
pc-1.2               Standard PC
pc-1.1               Standard PC
pc-1.0               Standard PC
pc-0.15              Standard PC
pc-0.14              Standard PC
pc-0.13              Standard PC
pc-0.12              Standard PC
pc-0.11              Standard PC, qemu 0.11
pc-0.10              Standard PC, qemu 0.10
isapc                ISA-only PC
q35                  Standard PC (Q35 + ICH9, 2009) (alias of pc-q35-1.5)
pc-q35-1.5           Standard PC (Q35 + ICH9, 2009)
pc-q35-1.4           Standard PC (Q35 + ICH9, 2009)

Installation fails (virt-install) for all machine types expect pc-i440fx-1.5 and pc-i440fx-1.4.

Thanks,
Chandrashekar



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]