[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [virt-tools-list] [libvirt-users] virt-manager 0.10.0 gentoo bug on start?



On 06/27/2013 11:52 PM, Doug Goldstein wrote:
> On Thu, Jun 27, 2013 at 11:54 AM, Cole Robinson <crobinso redhat com
> <mailto:crobinso redhat com>> wrote:
> 
>     On 06/27/2013 11:59 AM, Marko Weber | ZBF wrote:
>     >
>     > hello i installed virt-manager 0.10.0 on gentoo.
>     >
>     > on start i get:
>     >
>     > Fehler beim Starten des Virtual Machine Managers: cannot import name
>     > SpiceClientGtk
>     >
>     > Traceback (most recent call last):
>     >   File "/usr/share/virt-manager/virt-manager", line 303, in <module>
>     >     main()
>     >   File "/usr/share/virt-manager/virt-manager", line 267, in main
>     >     from virtManager.engine import vmmEngine
>     >   File "/usr/share/virt-manager/virtManager/engine.py", line 45, in <module>
>     >     from virtManager.details import vmmDetails
>     >   File "/usr/share/virt-manager/virtManager/details.py", line 37, in
>     <module>
>     >     from virtManager.console import vmmConsolePages
>     >   File "/usr/share/virt-manager/virtManager/console.py", line 28, in
>     <module>
>     >     from gi.repository import SpiceClientGtk
>     > ImportError: cannot import name SpiceClientGtk
>     >
>     >
>     > i dont set useflag spice. so why it alerts it cant import spice?
>     >
> 
>     virt-manager is discussed on virt-tools-list redhat com
>     <mailto:virt-tools-list redhat com>, CCing
> 
>     We just try to import it unconditionally regardless of whether the VM uses
>     spice. This could be fixed easily enough but my recommendation would be to
>     just install the necessary spice package.
> 
>     - Cole
> 
> 
> Yep. When I first packaged it up I had swore it detected what it needed so I
> made it optional for users to enable or disable it. I've since changed the
> package to require the full set of depends no matter the user's selection. 
> 

yes this did change with the latest release. I originally added the optional
bit because at the time spice-gtk wasn't widely packaged. But that reason
didn't apply anymore so it seemed like unnecessary complication.

- Cole


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]