[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[virt-tools-list] [PATCHv2 virt-viewer 0/4] Add version field in connection file



Hi,

It might be worthwhile to check for required client version before
establishing connection.

(I don't think it's worth to check for each capabilities and protocol
 version, this would only explose the number of combinations. I think
 it is better to assume that the min. requirement are checked during
 configure - assuming the respective backend needed are compiled-in,
 otherwise there is already a protocol required check error)

In v2:
- compare_version() doesn't deal with string suffix anymore
- fix misc review in 3rd patch

Marc-André Lureau (4):
  Add VIRT_VIEWER_ERROR GError
  Add virt_viewer_compare_version()
  Allow app_initial_connect() to raise an error
  file: add version field, raise an error if incompatibily

 src/remote-viewer.c             | 31 +++++++++++++--------
 src/virt-viewer-app.c           | 44 +++++++++++++++---------------
 src/virt-viewer-app.h           |  8 +++---
 src/virt-viewer-file.c          | 54 ++++++++++++++++++++++++++++++++++---
 src/virt-viewer-file.h          |  4 ++-
 src/virt-viewer-session-spice.c |  7 ++---
 src/virt-viewer-session-vnc.c   |  8 +++---
 src/virt-viewer-session.c       |  4 +--
 src/virt-viewer-session.h       |  4 +--
 src/virt-viewer-util.c          | 60 +++++++++++++++++++++++++++++++++++++++++
 src/virt-viewer-util.h          |  8 ++++++
 src/virt-viewer.c               | 43 ++++++++++++++++-------------
 12 files changed, 205 insertions(+), 70 deletions(-)

-- 
1.8.1.1.439.g50a6b54


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]