[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [virt-tools-list] [PATCHv2 2/4] Add virt_viewer_compare_version()



Hi

On Mon, Mar 11, 2013 at 9:45 AM, Christophe Fergeau <cfergeau redhat com> wrote:
> While I agree with Hans that we don't want to try to handle rc1, a, ...
> there, this code will also choke on versions like 0.18.13-09abc (which
> spice-gtk uses for git snapshots), this might be needed at some point

This is not a general version comparison function. Nevertheless, it is
trivial to drop the final -suffix before comparison.

I don't think it's a good idea to compare against each dependency. We
should rather bump version requirement at virt-viewer level, and be
done with one version check.

-- 
Marc-André Lureau


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]