[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [virt-tools-list] [PATCH virt-viewer 4/4] file: add version field, raise an error if incompatibily




----- Mensaje original -----
> On Thu, Mar 07, 2013 at 08:55:13PM +0100, Marc-André Lureau wrote:
> > The virt-viewer connection file can now have a version=0.5 field.
> > If
> > the virt-viewer version opening the connection doesn't provide at
> > least that version, an error is raised with the version required.
> 
> What is the anticipated use case for this ?  IMHO version based
> checks

Use case is: future version of ovirt portal may need/require a particular feature only implement in version X of virt-viewer (&dependencies). This is really required on windows, much less on unix-like.

> for user visible features are almost always the wrong thing todo,
> particularly if features can be disabled at build time with configure
> args. I prefer to see explicit feature checks

I would prefer we minimize the number of optionnal feature. We have enough complexity to deal with already.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]