[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [virt-tools-list] [PATCH 1/3] Fix exception with older gi versions



On 03/11/2013 04:21 AM, Giuseppe Scrivano wrote:
> The method gi.check_version was defined in 3.3.5.  Prevent an exception
> with older versions of the library.
> ---
>  src/virtManager/manager.py |    2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/src/virtManager/manager.py b/src/virtManager/manager.py
> index 991bcd7..7ca0861 100644
> --- a/src/virtManager/manager.py
> +++ b/src/virtManager/manager.py
> @@ -65,7 +65,7 @@ try:
>      import gi
>      gi.check_version("3.7.4")
>      can_set_row_none = True
> -except ValueError:
> +except (ValueError, AttributeError):
>      can_set_row_none = False
>  
>  
> 

For anyone reading, Giuseppe's patches are all against the gtk3 branch.

Applied now, and added you to AUTHORS.

Thanks,
Cole


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]