[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [virt-tools-list] virt-install does not work on 24-CPU machine ?



On 05/06/2013 08:12 AM, Laurent Pouilloux wrote:
> Hi,
> 
> I am trying to place VM on specific core using virt-install but it seems there
> is a problem with core number >12.
> The virsh capabilities returns:
> <topology>
>       <cells num='4'>
>         <cell id='0'>
>           <cpus num='6'>
>             <cpu id='0'/>
>             <cpu id='1'/>
>             <cpu id='2'/>
>             <cpu id='3'/>
>             <cpu id='4'/>
>             <cpu id='5'/>
>           </cpus>
>         </cell>
>         <cell id='1'>
>           <cpus num='6'>
>             <cpu id='6'/>
>             <cpu id='7'/>
>             <cpu id='8'/>
>             <cpu id='9'/>
>             <cpu id='10'/>
>             <cpu id='11'/>
>           </cpus>
>         </cell>
>         <cell id='2'>
>           <cpus num='6'>
>             <cpu id='18'/>
>             <cpu id='19'/>
>             <cpu id='20'/>
>             <cpu id='21'/>
>             <cpu id='22'/>
>             <cpu id='23'/>
>           </cpus>
>         </cell>
>         <cell id='3'>
>           <cpus num='6'>
>             <cpu id='12'/>
>             <cpu id='13'/>
>             <cpu id='14'/>
>             <cpu id='15'/>
>             <cpu id='16'/>
>             <cpu id='17'/>
>           </cpus>
>         </cell>
>       </cells>
>     </topology>
> which is OK.
> When I run
> virt-install -d --import --connect qemu:///system --nographics --noautoconsole
> --name=test --network network=default,mac=00:01:01:ab:cd:ed --ram=256 --disk
> path=/tmp/vm-base.img,device=disk,format=raw,size=2,cache=none --cpuset=0,1,2
> everything is ok.
> virt-install -d --import --connect qemu:///system --nographics --noautoconsole
> --name=test --network network=default,mac=00:01:01:ab:cd:ed --ram=256 --disk
> path=/tmp/vm-base.img,device=disk,format=raw,size=2,cache=none --cpuset=13
> I have a message telling me that the cpuset's numbers must be less than pCPU
> 
> 
> My machine is a bi-AMD Opteron(tm) Processor 6164 HE (12 core/cpu) with debian
> squeeze. I have tried with the squeeze packages as well as the wheezy one but
> it still fails.
> ii  libvirt-bin                         0.9.12-11                    programs
> for the libvirt library
> ii  libvirt0                            0.9.12-11                    library
> for interfacing with different virtualization systems
> ii  python-libvirt                      0.9.12-4~bpo60+1             libvirt
> Python bindings
> ii  qemu-kvm                            1.1.2+dfsg-6                 Full
> virtualization on x86 hardware
> ii  virt-viewer                         0.2.1-1                     
> Displaying the graphical console of a virtual machine
> ii  virtinst                            0.600.1-3                    Programs
> to create and clone virtual machines
> Is this a debian related bug or no ?
> 
> I have also post a bugreport if you are interested in.
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=953187
> 
> 

What's the output of 'sudo virsh --connect qemu:///system nodeinfo'

- Cole


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]