[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [virt-tools-list] Using Spice with virt-install



On 05/28/2013 12:23 AM, Diptanu Gon Choudhury wrote:
> Hi,
> 
> Just began installing virt-tools. Trying to install a windows 2008 server with
> virt-install and spice as the protocol to access the VDI.
> 
> Using the following command - 
> 
> sudo virt-install --connect qemu:///system --name WinServ2008 --ram 4096
> --vcpus 2 --disk
> path=~/Boxes/qemu/winserver2008.qcow2,format=qcow2,bus=virtio,cache=none
> --disk path=~/Downloads/virtio-win-0.1-59.iso,device=cdrom --cdrom
> ~/Boxes/iso/Win_2008_R2_64Bit_Standard_w_SP1_MLF_X17-22580.ISO
> --network=bridge:virbr0,model=e1000 *--graphics
>  spice,port=5901,listen=0.0.0.0* --accelerate --soundhw ac97 --os-type=windows
> --os-variant=win2k8  --noautoconsole --accelerate --noapic --keymap=en-us
> 
> 
> I am getting the error - ERROR    *Cannot mix --graphics and old style
> graphical options*
> 
> I would be glad if anyone cant point me to what I am doing wrong here. I
> couldn't find any spice example in the man pages of virt-install. 

The problem is combining --keymap with --graphics. You should use --graphics
...,keymap=en-us (but in reality, specifying the keymap here is likely
redundant and you can drop it).

That error should be improved to explicitly mention the conflicting option.
I'll take a bug report for it.

- Cole


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]