[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[virt-tools-list] Fwd: virt-install question



As recommended I am asking this question to the list instead of the individual developer.

-Stephen Herr

-------- Original Message --------
Subject: 	virt-install question
Date: 	Thu, 21 Nov 2013 15:34:11 -0500
From: 	Stephen Herr <sherr redhat com>
To: 	Martin Kletzander <mkletzan redhat com>



Hi Martin,

I'm working on cobbler / koan (specifically on the Satellite team). I
heard you were the maintainer for the virt-install package, and I have
some questions for you. I'm looking at virt-install-0.10.0-7.el7.noarch
if that makes any difference.

Due to python-virtinst being subsumed into virt-install and the python
module no longer being directly available in RHEL 7, the cobbler / koan
code has had to change. Esentially we just shell out to a command line
and call virt-install instead of communicating with the module directly,
like we did in RHEL 5 and 6.

The problem is with getting a list of os-variants that this version of
virt-install supports. We used to just 'from virtinst import osdict' and
look at OS_TYPES, but now that the module is not public we can't do that
any more. I see that with the command line tool you can do 'virt-install
--os-variant list', but the man page specifically says "The printed
format is not a stable interface, DO NOT PARSE IT." If I'm not allowed
to import the module and I'm not allowed to parse the output of the
command line tool, how exactly am I supposed to be able to detect if my
OS variant is supported by virt-install?

Thanks!

-Stephen




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]